Music playback shuttering/choppy?

Having Garmin zumo XT problems? there is loads of help and advice in this forum
MakoShark2
Posts: 23
Joined: 29 Jun 2021 12:06
Been liked: 5 times
Portugal

Music playback shuttering/choppy?

Post by MakoShark2 »

Is this a known issue? (couldn't fine anything on the forum).

Used it a couple of times it played fines.

Then yesterday on my way home it started well then got shuttering/choppy and finally couldn't hear anything.
rbentnail
Posts: 529
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 39 times
Been liked: 108 times
United States of America

Re: Music playback shuttering/choppy?

Post by rbentnail »

It depends how it's being used. Describe in detail your setup.
Russ B. Zumo 595,
2007 & 2013 USA Yamaha FJR1300A
jfheath
Posts: 975
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 253 times
Great Britain

Re: Music playback shuttering/choppy?

Post by jfheath »

What source ? Bluetooth or Mp3 on the Zumo XT itself ?
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
MakoShark2
Posts: 23
Joined: 29 Jun 2021 12:06
Been liked: 5 times
Portugal

Re: Music playback shuttering/choppy?

Post by MakoShark2 »

Sorry, I've just opened the App and tap play.

Source is the SD card on the Zumo, I have all my mp3 files there.
pangasuis
Posts: 17
Joined: 25 Apr 2021 17:49
Been liked: 4 times
Great Britain

Re: Music playback shuttering/choppy?

Post by pangasuis »

mine did this last time i was out too and i just thought it was the bluetooth connection to my headset that was dropping and didnt really think to much into it and i just stopped the music.

i normally use my phone to play the music which i have connected to my XT and my XT connected to my headset and never had a problem but the time it was stuttering and didnt work it was playing from my SD card in my XT because my phone didnt work after pouring water all over it :roll:

maybe its something to do with playing from the SD card?
jfheath
Posts: 975
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 253 times
Great Britain

Re: Music playback shuttering/choppy?

Post by jfheath »

The bluetooth connection is often the culprit. The BT on the Zumo is good - that isn't necessarily the fault. But if the device plsying the music is repeatedly trying to connect to other USB devices, this can cause an issue.
Unpair and forget every other device and make sure that neither XT or phone can go hunting for nearby devices. See if that cures the problem.

I gave up on using mine to play music from the phone. If I want music, I play it from the SD card, but I rarely use it.
I did all sorts of testing with other BT music sources and other BT players, and couldn't pin the problem to any single device. eg, The music played perfectly on the XT when sent from a different source. Which suggests the phone was at fault. But the phone played music perfectly when it was connected to a BT speaker. The same phone worked well with my Zumo 595. It seemed be the combination of android and XT.

I noticed that some problems started after connecting to the Explore account on the Garmin website, and would disappear when I reset or broke the connection. That problem also existed playing music from the SD card. But I got fed up with spending ages resetting and testing. I have not tried it again. My working theory was that the XT may have been struggling with all of the BT conversations eg from the Drive App. - weather, traffic, phone messages, BT module to support wired intercom and phone conversations.

I always used the SD card for music if I wanted it, and that works fine.

But its a long time since I tested it and there have been a few software updates.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
Iris
Posts: 68
Joined: 31 Jul 2018 01:17
Has liked: 1 time
Been liked: 5 times
United States of America

Re: Music playback shuttering/choppy?

Post by Iris »

I thought that GARMIN just recently had a BaseCamp update. I didn’t do the update because I just left on a trip. Anyway it said that the update was supposed to fix issues with (and I can’t quite recall) bt connectivity….something like that.
jfheath
Posts: 975
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 253 times
Great Britain

Re: Music playback shuttering/choppy?

Post by jfheath »

You are correct.

Current version 6.20 - May 2021 - fixed and issue that caused a communication problem with Basecamp. That wouldn't be a Bluetooth Issue though.

Here are the logs that I have managed to colelct together from Garmin Express. I am a few missing.

https://www.zumouserforums.co.uk/viewto ... 7892#p7892
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
MakoShark2
Posts: 23
Joined: 29 Jun 2021 12:06
Been liked: 5 times
Portugal

Re: Music playback shuttering/choppy?

Post by MakoShark2 »

Happened again.

And I think it's the audio switching back and forth with the audio speed warnings, at some time it started to shutter and finally gone quiet although the player was reporting the tune playing. Putting it on Pause or Play did not solve anything remained silent until a I rebooted...
electro_handyman
Posts: 97
Joined: 25 Apr 2018 11:47
Location: Iowa
Has liked: 1 time
Been liked: 18 times
United States of America

Re: Music playback shuttering/choppy?

Post by electro_handyman »

Mako, sounds like your issue is XT related.
I've used the XT music player and it will pause the playback to make it's announcements and then continue the playback when finished.
No issues with it being choppy or noisy.

Who is online

Users browsing this forum: CommonCrawl [Bot] and 3 guests