Garmin Zumo 390/395/396

For everything Garmin Zumo 390/395/396 related
  • Topics
    Replies
    Views
    Last post
  • Zumo 390 manual
    by Stu Great Britain »
    0 Replies
    17356 Views
    Last post by Stu Great Britain
  • 396LMT-S No Voltage at the cradle connector
    by Nielo Netherlands »
    2 Replies
    1723 Views
    Last post by msantibanez United States of America
  • Zumo 396 - What am I doing wrong?
    by Gomer United States of America »
    9 Replies
    155 Views
    Last post by jfheath Great Britain
  • formatted Garmin 396 Main Drive
    by cgdsclk Turkey »
    9 Replies
    951 Views
    Last post by cgdsclk Turkey
  • Duplicating internal drive on zumo 396
    by CRracer United States of America »
    17 Replies
    6387 Views
    Last post by cgdsclk Turkey
  • Zoom in on City Navigator Europe SD card
    by Coldrider Canada »
    13 Replies
    966 Views
    Last post by lkraus United States of America
  • Zumo 390 issue
    by airmav Greece »
    1 Replies
    654 Views
    Last post by QuantumQuartz United States of America
  • Zumo 396 LMT-S and Spotify
    by destes United States of America »
    2 Replies
    384 Views
    Last post by jfheath Great Britain
  • Power cord contact failure
    by lather United States of America »
    7 Replies
    3844 Views
    Last post by Totti Finland
  • Use Basecamp or Kurviger for planning?
    by jones9999 Great Britain »
    5 Replies
    750 Views
    Last post by jfheath Great Britain
  • Trip Planner - Shape Route Tool Non-Functionable
    by gfliger51 United States of America »
    0 Replies
    872 Views
    Last post by gfliger51 United States of America
  • 346/396 map detail gone/cant enter postcode
    by ianleics Great Britain »
    4 Replies
    1758 Views
    Last post by ianleics Great Britain
  • 396 recognises UK destination, then sends me to France!
    by Beery1 Great Britain »
    21 Replies
    6173 Views
    Last post by Beery1 Great Britain
  • 396 goes off and on by itself while navigating.
    by Fxwheels United States of America »
    21 Replies
    15468 Views
    Last post by Wallace Great Britain
  • Partial screen freeze up.
    by Purrtec United States of America »
    4 Replies
    3687 Views
    Last post by Purrtec United States of America
  • Zumo 390LM ‘On/Off button disintegrated!
    by Triops Great Britain »
    6 Replies
    3094 Views
    Last post by Triops Great Britain
  • zumo 390 trip planner problems
    by cachs005 Malta »
    0 Replies
    3695 Views
    Last post by cachs005 Malta
  • 396 Battery Level Check
    by twowheelstom Canada »
    3 Replies
    3162 Views
    Last post by Oop North John Great Britain
  • Where to connect 396 to 12v
    by twowheelstom Canada »
    5 Replies
    3016 Views
    Last post by twowheelstom Canada
  • 64gb sd card formatting
    by twowheelstom Canada »
    23 Replies
    7000 Views
    Last post by sussamb Great Britain
  • Starts Up on Motorcycle Cradle But Does Not Charge
    by VICXC12 United States of America »
    10 Replies
    9820 Views
    Last post by twowheelstom Canada
  • Seeking 396 Owners Opinions
    by twowheelstom Canada »
    8 Replies
    3002 Views
    Last post by MSTOCK27370 United States of America
  • Standard battery for Zumo 396.
    by gregjet Australia »
    2 Replies
    2906 Views
    Last post by gregjet Australia
  • Replacement LCD for 396?
    by baowow United States of America »
    1 Replies
    2929 Views
    Last post by jfheath Great Britain
  • Speed limit not displayed - SOLVED
    by Oliwally Australia »
    5 Replies
    3543 Views
    Last post by Oliwally Australia

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum