Not recognized

For everything Garmin Zumo 660/665 related
Posts: 1
Joined: 24 Jul 2021 17:53

Not recognized

Post by drduct »

Hello, I have a problem, Basecamp, Garmin Express, computer MO LONGER recognizes my 66o, has my GPS just died ? Anyone else experience this, updated maps approx 3 weeks ago, no issues, now nothing recognizes it, I have downloaded Garmin express fresh, I have tried everything I know, what have I overlooked, all help appreciated
User avatar
alan sh
Posts: 94
Joined: 23 Apr 2018 14:40
Location: Rochdale
Has liked: 5 times
Been liked: 26 times
Great Britain

Re: Not recognized

Post by alan sh »

Changed the cable? Tried a different USB port? Tried a different PC?

Do you have a friend with a 660? If so, can you try their device in your PC?
Owner of 3 Zumo 660's, one 346 and 2 bikes
Posts: 2245
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 278 times
Been liked: 608 times
Great Britain

Re: Not recognized

Post by jfheath »

Make sure that you have only one program trying to access your 660. Ie close down Basecamp if trying to use Express. and vice versa.

Also, if in Windows, CTRL ALT DEL to load task manager. Find any Basecamp or Express applications still running and terminate them. Also any other Garmin programs. They sometimes stay resident in the list of running programs, which can cause problems.

Today, I discovered something really important. I found another way that doesn't work.