660 LM not announcing turns

For everything Garmin Zumo 660/665 related
rbentnail
Posts: 437
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 33 times
Been liked: 88 times
United States of America

Re: 660 LM not announcing turns

Post by rbentnail »

Excellent! Pain in the butt but that seems like a relatively easy fix.
Russ B. Zumo 595,
2007 & 2013 USA Yamaha FJR1300A
Yodac
Posts: 6
Joined: 19 Jul 2021 13:20
Location: North Carolina
Has liked: 4 times
Been liked: 1 time
United States of America

Re: 660 LM not announcing turns

Post by Yodac »

Yes, I hope the info is helpful to others on the site.

Yodac
jfheath
Posts: 637
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 36 times
Been liked: 163 times
Great Britain

Re: 660 LM not announcing turns

Post by jfheath »

Well done for finding the answer - but I don't understand why it was announcing turns before your stop, if it was the English Language Files that were at fault. That doesn't make sense.

Unless it was the stopping the device and restarting it that cured the problem. My 660 used to do odd things after it had been navigating for a while. For example, the screen redrawing would start to get slow, then it wouldn't bother and I'd end up with a motorcycle icon and a track but no map drawn undernath it. Doing a restart always fixed it - which was possible to achieve on the move. The explanation that I gave to myself was that it had a 'memory leak', where memory is used by different functions but is not properly released when it the function finished - so the amount of available memory slowly went down. I don't know if that was what was actually happening.

It doesn't matter - you fixed it, and that is all that matters !
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone

Who is online

Users browsing this forum: CommonCrawl [Bot], Semrush [Bot] and 0 guests