590 Distance to Turn is Off

For everything Garmin Zumo 590/595 related
MSTOCK27370
Posts: 26
Joined: 05 May 2020 13:02
Has liked: 2 times
Been liked: 5 times
United States of America

590 Distance to Turn is Off

Post by MSTOCK27370 »

Not sure if this is a Zumo 590 issue or a Basecamp issue.

This is a new to me Zumo 590 LM (about a month), firmware is up to date. Map in the Zumo is CNNA 2021.1. I have two other LM Garmin GPS devices, three if you count the SP2610. Been using Map Source and Basecamp for several years.

Problem is simple. I start a planned route, leave my neighborhood and follow the directions to a traffic circle. When I exit the roundabout, the 590 says it is 3.7 miles to the next turn. This is correct, and matches the route in BC and the other GPS Zumo 550. In BC the route has a shaping point at an intersection 2.3 miles along this street. As soon as I pass that shaping point (I can see it on the 590 screen) the distance to next turn changes from 1.4 miles to 2.8 miles. As I get to the turn, the Arrow showing the turn is on the screen, but the distance to turn has counted down to 1.4 miles instead of being ZERO. I brought the 590 inside and turned on the GPS Simulator and the exact same problem happens.

Once I make the turn the directions sync up again, but it happens in one or two more places in the route. I know this trip well and don't need the directions but it makes me very uncertain about any new trip that I would build. So, is this a known problem? Is it because I placed the shaping point at an intersection? My PC has 2020.2 maps installed but when I connect the 590 I switch to the 2021.1 map and I recalculate the route so the route on the PC is using the same maps as the 590.

Michael
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

sussamb
Posts: 621
Joined: 23 Apr 2018 13:06
Has liked: 10 times
Been liked: 114 times
Great Britain

Re: 590 Distance to Turn is Off

Post by sussamb »

Is it just on this route or every route? I ask because it seems strange it goes from 1.4 to 2.8, an exact double. Are you on a divided highway? Is it possible you have points on the wrong side?

rbentnail
Posts: 291
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 17 times
Been liked: 51 times
United States of America

Re: 590 Distance to Turn is Off

Post by rbentnail »

When I read "the route has a shaping point at an intersection" a red flag went up immediately. I thought along the same lines as sussamb when I saw also the exact doubling of the mileage. I thought "overpass and the device wants the road under it"? It sounds like the device is running a loop on the route twice. Move that (those) shaping points off the intersections and see what happens.
Russ B. Zumo 595,
2007 Yamaha FJR1300A, 128k and counting

MSTOCK27370
Posts: 26
Joined: 05 May 2020 13:02
Has liked: 2 times
Been liked: 5 times
United States of America

Re: 590 Distance to Turn is Off

Post by MSTOCK27370 »

sussamb wrote:
12 Jun 2020 21:42
Is it just on this route or every route? I ask because it seems strange it goes from 1.4 to 2.8, an exact double. Are you on a divided highway? Is it possible you have points on the wrong side?
I've loaded a couple of routes into the 590 just to give myself a chance to become familiar with the different functions and capabilities. Like I said, the problem happens in at least two or three other spots in this route and I think it also happened in the other route I loaded and tested.

This is a small two-lane road. It is not divided. I've checked the shaping points, they are on the road and it doesn't go back on itself. When I look at the directions in BaseCamp they are correct. When I look at the list of points, they are correct. The directions list in the 590 are correct. It is just at the moment that I pass the intersection, that the remaining distance to turn doubles. In all of the other instances where this has happened, I haven't noticed the issue until I got to the next turn and saw that the distance to turn wasn't zero, it was some other distance. This one road and turn are close enough to home that I was able to examine all the pieces pretty closely.
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

MSTOCK27370
Posts: 26
Joined: 05 May 2020 13:02
Has liked: 2 times
Been liked: 5 times
United States of America

Re: 590 Distance to Turn is Off

Post by MSTOCK27370 »

rbentnail wrote:
12 Jun 2020 23:07
When I read "the route has a shaping point at an intersection" a red flag went up immediately. I thought along the same lines as sussamb when I saw also the exact doubling of the mileage. I thought "overpass and the device wants the road under it"? It sounds like the device is running a loop on the route twice. Move that (those) shaping points off the intersections and see what happens.
The road is a two lane country road. There is no overpass and it isn't divided. I was questioning the same thing about the shaping point at an intersection. Keep in mind that this shaping point was put there just to keep the route on this road, not for a turn to another road. So, it is a simple matter to move the shaping points down the road a hundred yards so it is away from any intersection. Since I was able to duplicate the problem at home with the simulator, it should be easy to test. Just asking to see if this was already a known problem and if the advice is never put shaping points at the intersection? - Michael
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

MSTOCK27370
Posts: 26
Joined: 05 May 2020 13:02
Has liked: 2 times
Been liked: 5 times
United States of America

Re: 590 Distance to Turn is Off - SOLVED

Post by MSTOCK27370 »

I believe this problem is resolved. A road trip will settle it for certain.

I created a short test route which duplicated the original circumstance with a shaping point placed on the road being traveled and at an intersection. The original route was completely reviewed and all of the shaping points on the road placed at an intersection were moved away from the intersections by a few hundred feet. Shaping points where the route had a turn were left at the intersection.

The test route produced the same error as described in my first post. The revised route produced turns, directions and distances exactly as expected and matched the original figures produced by Base Camp. These results were on the 590 while running with GPS simulation. If any of this changes when I run the route on the road I will update my findings.
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

MSTOCK27370
Posts: 26
Joined: 05 May 2020 13:02
Has liked: 2 times
Been liked: 5 times
United States of America

Re: 590 Distance to Turn is Off - SOLVED

Post by MSTOCK27370 »

Used the 590 out on the road yesterday and the revised route is now providing accurate distance to turn numbers. Moving the shaping points away from the intersection of another road fixed the problem.
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

rbentnail
Posts: 291
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 17 times
Been liked: 51 times
United States of America

Re: 590 Distance to Turn is Off - SOLVED

Post by rbentnail »

MSTOCK27370 wrote:
16 Jun 2020 02:53
Used the 590 out on the road yesterday and the revised route is now providing accurate distance to turn numbers. Moving the shaping points away from the intersection of another road fixed the problem.
WooHoo! :lol:
Russ B. Zumo 595,
2007 Yamaha FJR1300A, 128k and counting

jfheath
Posts: 161
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 41 times
Great Britain

Re: 590 Distance to Turn is Off

Post by jfheath »

Curious.

But as a general rule I never, ever, ever put a route point on an intersection. I always put the point after a junction, some way up the road on which I want to be traveling.

Doing that can solve all sorts of problems.

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest