SYNC-ing theGarmin Zumo XT - Music transfers

Having Garmin zumo XT problems? there is loads of help and advice in this forum
User avatar
Posts: 388
Joined: 24 Aug 2020 14:36
Location: Central Ohio
Has liked: 54 times
Been liked: 123 times
United States of America

SYNC-ing theGarmin Zumo XT - Music transfers

Post by lkraus »

SYNC - ing the Garmin Zumo XT

If you are satisfied with the way your PC connects to a Zumo XT, you can move on to another post.

Short version:
My new Garmin Zumo XT (v6.30) was not properly recognized by my main Windows computer, using any of its USB 2.0, USB 3.1(Gen1), or USB 3.1(Gen2) ports.
It did appear as a generic Portable Device in Device Manager. I could read/write files with File Explorer. Garmin Express could access it for updates, Basecamp could access the Zumo's maps and transfer data to it.
What the Zumo XT could NOT do was be recognized by media managers. Neither Windows Media Player nor my preferred Mediamonkey could find it to sync (transfer music).
I've not seen any mention of this or a similar issue with a Windows PC.
After ~20 hours of work spread over four days I came up with a single method that installs and registers the drivers completely.

In short, turn on the Zumo, tap View Map, tap the speed indicator to reach the trip computer screen, then press and hold the speed circle until the Diagnostics Page appears.
Select Configuration and Settings, then MTP Settings, then MTP Mode.
Select either of the "USB Ethernet" options, and Save.
Hold down the back button to return to the main screen.
With the Zumo still turned on, connect the USB cable to the computer through a USB 3.0 hub.
When the Zumo recognizes the USB connection, press continue to use file transfer mode, wait a bit while the drivers are installed.
Notifications should pop up, one of which says it is setting up Autoplay.
When complete, File Explorer and Device Manager will show the Zumo XT as a Portable Device with a blue Garmin triangle icon instead of a generic MP3 player icon.
Once the drivers are completely installed, the hub is no longer necessary, and any of the MTP settings can be used.
All the media managers I've tried can now see the XT to sync music files.

I can find no information online about "USB Ethernet". It is NOT Mass Storage mode. Other than letting the drivers install properly, that mode has only one apparent difference from "MPT Auto Detect".

With the Zumo turned off:
  • In MTP Auto Detect mode, the Zumo turns on when the USB cable is connected to power and asks to go into File Transfer mode.
  • In USB Ethernet mode, the Zumo turns on when the USB is connected to power and does NOT offer to go into File Transfer mode.
I ran some errands yesterday, and tried out my Zumo in the car, in MTP Auto Detect mode, and powered by a USB socket. It attempted to go into file transfer mode every time power was applied. Selecting USB Ethernet mode would have avoided the need to cancel File Transfer mode every time I switched on the ignition.

I'm posting this in a couple forums in hopes of helping someone else. If I lose my notes and forget what I did maybe Google will remember.

Longer version:
My tale of woe and hair-pulling and what did NOT work. Skip it if you want to stay awake.

My main computer is a fairly powerful desktop, just 18 months old. Uses Windows 10 Pro. Works great with my Zumo 590/595. I use Mediamonkey (MM) to manage about 100Gb of music files and audio books. It makes it easy to change the music I use on my phone and the 595. I can select individual songs, albums, custom playlists, random selections based on any number of criteria. It automatically converts file formats to match the device before transferring.

So after I used Garmin Express to update my new XT, selected my preferred settings, saw how Basecamp liked it, played with BirdsEye, the next obvious step was to add a SD card and load some music. But MM could not see it, so I could not sync. Aaaargh...

I'm too tired to detail all the nonsense I tried to get this working as well as the 595, though I do have some lengthy notes. Take the items below, which are not in order, stir well, pick out as many or as few as you like and I probably tried that combo. Several times.

Update drivers in Device Manager - already current (as is all software on this computer)
Tried "Run as Administrator" wherever possible, even though I am the Admin user.
Different cables, no change from the Garmin cable (I need a longer one)
Uninstall drivers,rescan and reinstall or just uninstall and reboot (same difference) (probably 50+ times)
Reset the XT
Tried Windows Media Player, installed and tried three other media managers, still no sync with any.
Tried different computers
  • Netbook with 32 bit Windows 10 Home - XT syncs!
  • Very old, slow laptop with Windows 7 Ultimate - XT syncs!
  • Wife's year-old laptop, 64 bit Windows 10 Pro - NO sync (A pattern? yes, but it's not the OS)
I noticed that the PCs that sync have a blue triangle icon in Device Manager, those that don't sync use a generic MP3 player icon. (first good clue)

Device Manager>Driver Details shows similar driver names, just differences in OS.
Searches on the Garmin website were useless.

Lots of Googling
Many variations on MP3 player not seen, USB Ethernet(nobody ever heard of it, except as it relates to networking adapters and Garmin users who were questioning what it was), and more.
Confirmed Windows 7 and 32bit Win10 drivers will not work in 64bit Win 10.

Learned a lot about the Event Viewer.
This turned up on every incomplete reinstall attempt:
  • "Microsoft-Windows-WPDClassInstaller 25089 Driver Migration It was not possible to access the device () after installing drivers. Error code 0x80070651."
Google found lots of hits, but no applicable solutions to that result.

This computer has nine USB ports that accept the Garmin cable, the Zumo has two MTP modes, I tried all three modes in all nine ports (getting desperate) I did discover the difference MTP mode makes in start-up when the cable is connected, but still could not see the XT in MM.

Tried variations starting with power on vs. start with power off.

I remembered some Mac users reporting that they could not connect to their XT at all without using a USB hub (which Garmin says not to use). I'll try anything by now.

I have a USB 2.0 hub and a USB 3.0 hub. I found the 3.0 version first, tried it in different types of ports, still no sync, no blue triangle. Tried the USB 2.0 hub in a couple ports, still no sync.

Finally switched to USB Ethernet mode, with the 3.0 hub, using the steps up top, and it all just worked.
There was an extra beep or two, a couple pop-ups, one advising that Autoplay options were being set up, the Zumo XT entry in Device Manager had its blue triangle icon, and MM saw the Zumo!

For the sake of completeness (stupidly brave soul that I am), I uninstalled the Zumo again and tried to re-install using the three port types and the USB 2.0 hub in USB Ethernet mode. It did not work.
Back to the using 3.0 hub, I tried one of each type of port (2, 3.1(Gen1), 3.1(Gen2). All those installations were successful.

Afterward I found some info in the Event Viewer:
  • Microsoft-Windows-WPDClassInstaller 24576 Driver Installation Drivers were successfully installed for device USB\VID_091E&PID_4D9C&REV_0008.
  • Microsoft-Windows-WPDClassInstaller 24577 Driver Post-Install Configuration Media player and imaging program compatibility layers were successfully registered for device USB\VID_091E&PID_4D9C&REV_0008. Layer bits 0x00000003 were requested, layer bits 0x00000003 were registered.
  • Microsoft-Windows-WPDClassInstaller 24578 Driver Post-Install Configuration Autoplay was successfully registered for device USB\VID_091E&PID_4D9C&REV_0008.
The first line had appeared for the incomplete installations but the second two did not, so those are the steps skipped after "Driver Migration It was not possible to access the device () after installing drivers. Error code 0x80070651".

I have no idea why adding the 3.0 hub makes a difference to the installation. Google tells me USB 3.1(Gen1) is the exact same thing as USB 3.0.

Now that the driver "registration" is complete, all nine ports can be used to sync, with or without the hub.

Total speculation, just a guess by an ignoramus about a theoretical possibility about what could have maybe happened in an imaginary universe: After being installed the driver needs a tiny fractional second to "initialize" before the Zumo can be queried about its capabilities and/or "registered". The query is being made before that initialization is complete, and using the hub delays the request just long enough that the query succeeds. Or something like that.

The old laptop (that worked first try) is very slow and has only USB 2.0 ports. I'm assuming the XT is USB 2.0, since Garmin provided a (black connector) USB 2.0 cord, but it could very well have a faster processor and be able to complete my theoretical initialization before the laptop is ready to "register" it.

The netbook (that also worked first try) is basically a Windows touch tablet, with a detachable keyboard attached to the side with a special latch/hinge/connector. The body of the keyboard contains a spinning hard drive and the only USB port, a 3.0. Looking at Device Manager, the hinged connector is appearing as a USB 3.0 hub connecting the keyboard, hard drive, and USB port. So I was using a hub when I connected the XT even though I did not realize it. Plus the Atom processor is no speed demon.
Last edited by jfheath on 29 Jul 2022 08:46, edited 1 time in total.
Reason: Typos
2006 R1200RT
Galaxy S10<>Zumo XT<>Sena 20S
Posts: 2492
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 322 times
Been liked: 679 times
Great Britain

Re: SYNC-ing theGarmin Zumo XT - Music transfers

Post by jfheath »

Wow Larry

Brilliant stuff. I often wondered what USB ethernet meant. I assumed that it involved using a device that I didn't have and never bothered to investigate further than noting that it didn't work.

I still don't know what it means, but at least you have been able to make it do something.

MTP (Media Transfer Protocol) allows the USB cable to be disconnected without having to formally close the USB connection in Windows first. It doesn't cache the data. Caching data is generally ore efficient, but it leaves the last chunk of data to be sent in the cache on the computer rather than where it should be in the Zumo. As a consequence, you cannot open a file on the XT in MTP mode to edit it. You have to send it to the computer, edit it there and then save the new file back. *****

Whatever, you may need to check whether or not you have to formally 'unplug' the connection at the Windows' end before pulling the cable

Now you've done it. I'm going to have to play - and I've only just got my replacement XT having 'broken' my first one. It just died. Froze on the bike at 3mph and would power off, but could not be revived.

It is still on 6.20 at the moment.

I wondered what I was going to do in the run up to Christmas.

Fascinating stuff. And I didn't fall asleep half way through either. I do when Im proof reading my own stuff !


**** Aha. You may have inadvertently found the reason for a fault that I reported a year ago and which has not been addressed yet v6.30.

I wonder if this is why the XT overwrites and effectively loses previously transferred files in temp.gpx. And why only the last set of favourites / waypoints to be transferred can be made to appear on the XT map as hearts. I bet it is. ****


No it wasn't. Those problems still exist in USB transfer mode - so that isn't the reason. I was getting quite excited by that possibility.
Have owned Zumo 550, 660 == Now have Zumo XT2, XT, 595, 590, Headache
Use Basecamp (mainly), MyRouteApp (sometimes)

Links: Zumo 590/5 & BC . . . Zumo XT & BC
Posts: 2492
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 322 times
Been liked: 679 times
Great Britain

Re: SYNC-ing theGarmin Zumo XT - Music transfers

Post by jfheath »

I started to experiment with your findings. In USB Ethernet mode - you quite rightly say that it just turns on if you connect from cold, but if you plug in the USB cable when the XT is already on, it prompts to make the connection - and then it begins a count down from about 2 billion, in seconds. (Actually 2^31 -1 - so I guess it has a 32 bit processor). That works out to be just over 68 years before it goes into file trasnfer mode. I'm 68 next year. Alarming to see the seconds of my life ticking down like that.

But some odd things happened. Windows wouldn't recognise my USB connection at all. I'd been using it to test transfers and updating software and other Garmin updates - all using USB Ethernet. Then it decided to pretend not to know me. I tried the USB hub, the direct USB port on the PC, different cables. Nothing. It would recognise my camera and my phone. Not the XT.

So I shut down and restarted windows. I shut down and restarted the XT and I plugged the XT into a different port. Then I got the option to tell windows what to do with the connection. I chose synch media player. And that did the trick. The Zumo opened up Media player whether it was plugged into the hub, the PC port or with either cable. It needed to think it had got a new device and restarting Windows seemed to help.

I also discovered something which I knew had to be there, but had never looked for it in Windows 10. Settings->Devices->Autoplay and in there you can set what happens - just like when it finds a new device. The blue triangle seems to come from Media Player.

Again - thanks for your post. Good to find out new stuff.

Did I get the impression that USB Ethernet is faster? I thought it, but logic tells me that it was my imagination. It uses the same port and the same cable.
Have owned Zumo 550, 660 == Now have Zumo XT2, XT, 595, 590, Headache
Use Basecamp (mainly), MyRouteApp (sometimes)

Links: Zumo 590/5 & BC . . . Zumo XT & BC