Won't connect to computer

For everything Garmin Zumo 590/595 related
mauritswoudenberg
Posts: 8
Joined: 01 Apr 2022 08:28
Been liked: 1 time
Netherlands

Won't connect to computer

Post by mauritswoudenberg »

Hi all,

As I mentioned in my previous post and currently on a round the world trip on my motorcycle.

My 595 does not want to connect to the computer. WHen I plug in the USB cord it shows the orange computer / gps connection image but then it restarts and acts loike it's just charging and not connected to a computer.

Does anyone know how to fix this? It's the same for mac and windows and with different cords / computers.

Hope anyone can help!

Best,
Maurits
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Won't connect to computer

Post by jfheath »

The best I can suggest :

The cable needs to be Charge and Synch - not just charge. I have one cable that does what you describe.

Maybe the USB connector is not making good contact. Try holding it in position with a bit of pressure on one side - see if it makes a difference.
I've just moved my cable around where it plugs into the 595, and it disconnected from the computer, having been showing the Orange computer on the screen.

Check that you don't have other programs running on you computer that are trying to access the USB (Garmin Express and Basecamp have issues when they are both run together).

Check the type of connection in the settings

Main Screen / View Map / Tap Speed button, bottom left / Tap and hold the circular speedo display top centre. 10 seconds.
This enters Diagnostic Page
Configuration and Settings / MTP Settings

There are three options. Typically it will be set to MTP Auto Detect.
Others are Mass Storage
MAss Storage single Session

MTP is media Transfer Protocol. The Zumo behaves like a media device and can be conencted and unplugged at will
Mass Storage - the device behaves like a disk drive and gives you one or two new drive letters.

If one isn't working, the other might.

The single session options runs Mass Storage the next time it starts up, and then the next time after that, it goes back to MTP.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
mauritswoudenberg
Posts: 8
Joined: 01 Apr 2022 08:28
Been liked: 1 time
Netherlands

Re: Won't connect to computer

Post by mauritswoudenberg »

Hi,

Thank you for your suggestions.
Unfortunately I ruled out cable & computer. I also tried some light pressure on the usb contact, but it didn't work. I think the usb connection is fine because it does recognize a computer (orange pc screen, and grey pc screen when selecting mass storage. The zumo just restarts itself and then boots into normal startup like its only charging.

Any other options that anyone can think of?

Thanks again!
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Won't connect to computer

Post by jfheath »

It displays the computer on the screen before it has started the connection to the computer. So it is recognising that the cable is connected to something. But then it doesn't establish communication - so it suggests that the connector or the cable is dodgy to me. Especially since mine does the same thing if I use a particular cable and disturb it. I have to put the Zumo screen face down so that the cable is sticking straight up and cannot be disturbed. I don't know if the issue is with the connector, the wire or the soldered joints on the circuit board.

I just know that I keep the number of times that I plug the cable into the Zumo to a minimum. I leave the cable in at the Zumo end and disconnect from the PC when I am using it.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
rbentnail
Posts: 529
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 39 times
Been liked: 108 times
United States of America

Re: Won't connect to computer

Post by rbentnail »

The other thing I found is the computer's usb ports. My laptop has 3 but 1 is useful for 595 charging only, no comms. I have to use one of the other two for comms with Base Camp to work.
Russ B. Zumo 595,
2007 & 2013 USA Yamaha FJR1300A
mauritswoudenberg
Posts: 8
Joined: 01 Apr 2022 08:28
Been liked: 1 time
Netherlands

Re: Won't connect to computer

Post by mauritswoudenberg »

I'm a bit embarrassed to say this but I think it was indeed the cable... I brought 3 micro USB cables with me, and all of them worked for both charging and data on multiple devices (e-reader, card-reader), but after trying a borrowed fourth one it actually did connect.. My bad, thanks for convincing me to keep suspecting the cable.

Cheers!
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Won't connect to computer

Post by jfheath »

No problem, I'm glad that it worked.

And thank you for feeding back - it helps others who are reading the posts in the future to try different things.

I have 5 of these cables - I have a number of devices that use the same style of connector. One of them doesn't work for data. One day I will remember to label it. But where's the fun in that.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests