Zumo 595 wont pair with BMW System 6 helmet

For everything Garmin Zumo 590/595 related
BrickHead
Posts: 7
Joined: 05 Nov 2018 23:09
Great Britain

Zumo 595 wont pair with BMW System 6 helmet

Post by BrickHead »

I have been using my Zumo 550 for many years and it runs with my BMW System 6 helmet and Bluetooth without any problems.
My son purchased a new Zumo 595 for me as a Christmas present and have spent all day trying to get it to pair with my system 6 system.
Refuses to talk whatsoever and have noticed that the Audio Software is shown as 2.2 and somewhere I read it needs at least Audio Software 2.5 to work with a BMW system?
Have used Garmin Express today and loaded it up from the internet but still shows Audio Software 2.2 and mapping version 4.60 and of course will not speak to my crash helmet. Turned it off and turned on the old Zumo 550 and hey presto works a treat as usual. Have unpaired it from my 550 but still no luck.
Anybody out there who has had this same problem as I am getting fed up wasting a whole day trying to get this Zumo to run. Had also been on the chat line today but the person trying to help did not seem to know about audio software up dates on Zumo's.
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Zumo 595 wont pair with BMW System 6 helmet

Post by jfheath »

I don't have the BMW kit, but I have a cheapo audio headset.

I have a 590 which has audi version 2.2 and it is connecting the 590 and to the phone OK. I can easily make this into a 595 to test things out, but the hardware is the same whatever software I install.

It just had a few hiccups - cutting the sound out - which turned out to be the phone reconnecting to a device downstairs - which lets me play music through the amp and speakers. As soon as I unpaired that, its working a treat.

The 590 and 595 have a weird set up regarding phone, music and such like - becasue it has both wired connections and bluetooth and you can select where you want the sound to go and where you want it to come from.

They are also very sensitive to other devices which might be trying to connect. If one device momentarily disconnects, the chances are that either or both will find something else to connect to.

I will still occasionally have problems if I try to set things up when the bike is just outside the house, just before I set off. I've stopped trying, and will spend a couple of minutes further up the road powering things on with nothing present that any device has been paired to in the past.

I put together the attached when I was having problems. I know its not the same kit, but it might help.

I posted it here. Follow it step by step. Don't take shortcuts. It will help to eliminate problems.

download/file.php?id=250

But bear in mind I know othing of any issues with BT and the BMW kit. Sometimes though issues like the ones that I have mentioned crop up and someone with v 2.5 gets it to work and someone with v2.2 doesn't - and the assumption is made. I'm not saying that is what has happened, but it is a possibility.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
BrickHead
Posts: 7
Joined: 05 Nov 2018 23:09
Great Britain

Re: Zumo 595 wont pair with BMW System 6 helmet

Post by BrickHead »

Decided to take out the battery last night of my Zumo 595 and today plug it back in as nothing seemed to work to pair it up with my BMW System 6 helmet. Hey presto this morning it has now paired up with my Zumo and can also pair it up with the BMW system on the bike.
Have no idea why it now works but problem seems to have vanished.
As it had never been paired with anything else having been bought and not used from new it could not have been used with other Bluetooth equipment.
Problem solved.
Just a pain having used the Zumo 550 since it came out years ago and see an expensive Zumo sold to the public with a far dimmer screen , assume they got the message with the XT model.
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Zumo 595 wont pair with BMW System 6 helmet

Post by jfheath »

Good stuff.
DOn't forget to check the brightness setting on the 590. It automatically dims, and doesn't always come back up to 100%. Yes it isn't as bright as the XT, but I always found it to be usable. My 590/595 cradle is going back on the bike this weekend in addition tot he XT. Keeping my options open.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone

Who is online

Users browsing this forum: Bing [Bot], CommonCrawl [Bot] and 1 guest