Waypoint icons

Having Garmin zumo XT problems? there is loads of help and advice in this forum
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Waypoint icons

Post by jfheath »

ianchapp wrote: 10 Mar 2022 12:51 Just tried Explore for the first time. Not sure if I love it or hate it - probably the latter! :D
Bits of it are great. Not enough for me to keep it active all of the time though.
ianchapp wrote: 10 Mar 2022 12:51 The icons are certainly far more presentable. It looks to me like Garmin are trying to persuade you to use their cloud. The fact that it doesn't retain existing icons in the GPX is annoying. But what makes it worse is that I can't seem to bulk-edit waypoints' icons, which TBH makes it a non-starter for 1000+ of them. Or am I missing something? Maybe it's possible to set a default prior to import?
There doesn't seem to be any compatibility with Garmin's previous notion of Waypoints, that I can see.
Bulk edit is available for most entries on the Explore website. (I'm using a browser on the PC - I haven't tried the app on a smartphone).
Get your waypoints in a column on the left hand side. Click the top one. Hold down the shift key and click the bottom one.
Click the edit icon for any one of the items that you have multi-selected. The change is made to all of the selected items.
You can delete in the same way, and shift multiple items into a collection in a similar manner.
ianchapp wrote: 10 Mar 2022 12:51 The other 'problem' is that notes associated with a waypoint (critical route info in the TET's case) appear not to be stored with the waypoint?
I'd never thought about this before. So I just had a look. The Waypoints that I had created before enabling Explore had an address, post code and telephone number. These were all displayed on the Favourite screen when I selected the same item after enabling Explore. But although the address and phone number were visible on the Favourite Info screen, there was no way of being able to edit them, or to enter similar information on the Explore web site.

So I disabled Explore on the XT. Again there is no way to edit the address from the Zumo, even though it is still visible in the information. But if a phone / headset is connected then the information(i) button for the Waypoint will reveal the telephone number which can be edited using the 3 bar menu, and the Call facility becomes available. It isn't there unless you have the phone and a headset connected. Neither is it there if a phone number wasn't stored with the original Waypoint. It seems to be impossible to add one either through the XT or through Explore.

With / without Explore enabled, it is possible to find a location in Categories or in the FourSquare database. Add that as a Favourite and then the information is displayed, and the phone number can be edited and called from the Favourite Information Screen.

So it appears that if the waypoint had that info in the first place, Explore may not allow you to see it or edit it, but the original info is still available on the XT screen from within Favourites.
ianchapp wrote: 10 Mar 2022 12:51 And if I disconnect from Explore (using hidden menus), do my waypoints disappear?
They are not accessible from the XT when it doesn't have Explore connected. But providing that they have not been deleted from the 'Explore website', then when you reconnect, they will reappear on the XT.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
ianchapp
Posts: 18
Joined: 18 Feb 2020 18:17
Has liked: 4 times
Great Britain

Re: Waypoint icons

Post by ianchapp »

OK I've been playing around with various options:

The reason I couldn't 'bulk edit' in Explore (in a browser) was that I was trying it on Unorganised items (where they appear with checkboxes to their left). For some reason bulk edit appears to only be possible within Collections, a slightly different interface. So, that problem's solved! :D

Regarding Waypoint info (known as a Comment in MapSource, Notes in BC), as far as I can see this info never gets transferred to the XT, either using Explore or the old off-line method. Which is a major problem IMHO. I'm just charging my last unit (a 550) to check the same GPX transfers the info OK (pretty certain it does). The other bizarre thing is that within the Explore app (Android), you can add notes. But these notes aren't accessible in a browser, and nor do they appear on the device. Totally isolated (= useless) as far as I can see.

One other thing I've noticed is that the browser interface often fails to import a GPX if the Waypoints do contain a comment/info. In most (all?) cases I had to strip the comments first to get the import to succeed.

The only way I've been able to get this info onto my device is within POI's, which seem very fast and efficient. If I could get them to display permanently on the unit, and assign an icon, I'd be happy. But the suggested method of having MyFile.gpx and MyFile.bmp in the same folder doesn't seem to work, on the XT at least. I'm sure I have the icon size and BMP type correct. No icon assigned, let alone displayed. I had thought I could get around the lack of visibility of POI's by using proximity alerts, but as far as I can see these only fire when they're on or very close to a road route, they don't work off-road.

So the only way I've managed to achieve what I want (icons always shown, and info available) is to duplicate the info. First as Explore icons, Second as POI's for the info. Seems to me a ludicrous situation.
jfheath
Posts: 985
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 84 times
Been liked: 255 times
Great Britain

Re: Waypoint icons

Post by jfheath »

Interesting points you raise.

I'm going to have to go back to this. Somehow the phone number and address gets into a Waypoint fromBasecamp and it appears on the Zumo. Whether these are entered into the Waypoint dialogue box in BC or whether they need to come from a stored POI I don't know. I think that since Waypoints have the same dialogue box as the points from the Basecamp database, I assumed that this info did get transferred.

Som other info also gets transferred in the gpx file, but the Zumos don't seem to take much notice of it.

But Categories does get transferred and the Zumo can use it. You just make up your own category and the ZUmo will display all of the points that belong in that cetegory. Notes, I have never used.

I played with POIs and had them marking objects of interest that were well off road, and they alerted me when I got within 2 miles of them. It was a long time ago though. I had grand ideas of devising a treasure hunt based on these - but I didn't progress when I realised that anyone who had the nouse to read the gpx file, would be able to locate the point precisiely without following the spoken clues.

I'll have a play, see what I can find out. It won't be immediately though !
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
ianchapp
Posts: 18
Joined: 18 Feb 2020 18:17
Has liked: 4 times
Great Britain

Re: Waypoint icons

Post by ianchapp »

jfheath wrote: 13 Mar 2022 19:58 Interesting points you raise.
...........
I'll have a play, see what I can find out. It won't be immediately though !
I put together the attached PDF trying to explain the problems to Garmin UK (a guy called Thomas). I knew I was optimistic expecting a decent reply. Apart from recommending that I submit a suggestion, all I had was this:

I have checked on this further for you internal. Unfortunately, Certain icons from basecamp are not able to go over to the device when sending the waypoints to the unit, basecamp will only send the waypoint across to the device and not send the notes or icons. This is a limitation of basecamp.

Truth is that it's nothing do with BC, it's more to do with the XT. A GPX created in MapSource, and transferred via Windows Explorer exhibits the same problems.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: Bing [Bot], CommonCrawl [Bot], Semrush [Bot] and 2 guests