Locking on mount doesn't feel like its latching right

Having Garmin zumo XT problems? there is loads of help and advice in this forum
spike747
Posts: 6
Joined: 19 May 2020 03:51
Canada

Locking on mount doesn't feel like its latching right

Post by spike747 »

I just picked up a XT and the first thing I noticed is the locking mechanism doesn't have a very positive feel to it when it engages. On my 590, I was always confident when it clicked in, but with this XT, it can't hear or feel it. I've been pushing hard on it and yanking back on it to check. This sucks. Is this the way these are or do I have an XT with bad casing? O, by the way, I bought the car kit and that adapter feels the same way. So I know its the body of the XT doing it.

Thanks.
Hati
Posts: 76
Joined: 25 Dec 2019 22:12
Has liked: 2 times
Been liked: 15 times
Australia

Re: Locking on mount doesn't feel like its latching right

Post by Hati »

Sounds like you got the second batch of mounts, the replacement for the sloppy, less secure ones the XT was released with. I got my original one replaced and feels just like you describe it. Seems to lock securely though, I had no problems over a considerable amount of riding since it was changed.
User avatar
simoncrewe
Posts: 165
Joined: 27 Sep 2019 15:45
Has liked: 36 times
Been liked: 29 times
Great Britain

Re: Locking on mount doesn't feel like its latching right

Post by simoncrewe »

spike747 wrote: 29 Dec 2020 04:37 I just picked up a XT and the first thing I noticed is the locking mechanism doesn't have a very positive feel to it when it engages. On my 590, I was always confident when it clicked in, but with this XT, it can't hear or feel it. I've been pushing hard on it and yanking back on it to check. This sucks. Is this the way these are or do I have an XT with bad casing? O, by the way, I bought the car kit and that adapter feels the same way. So I know its the body of the XT doing it.

Thanks.
You are spot on, the standard mount feels very flimsy compared to other models, especially the rugged mount of the old Montana & Monterra. When I first got my unit back in March, I ran it on my bike with a stick on 'tether' to the rear of the unit for added peace of mind. I have subsequently purchased the Touratech locking mount & the whole set up is now bullet proof.
Garmin did have an issue with loose mounts on the early released models, but that was back in March/April & it has subsequently been rectified, so if yours is a brand new unit, you will have the latest mount.
When you mount the unit, I always make sure the 'lip' on the mount is seated in the rear of the XT itself before I click the unit home. When using the car mount, the release clip needs to be at the bottom of the XT unit.
Exurban
Posts: 33
Joined: 23 Jul 2018 15:36
Has liked: 5 times
Been liked: 8 times
United States of America

Re: Locking on mount doesn't feel like its latching right

Post by Exurban »

I got mine somewhere around June. I can’t recall if it has a resounding click or not but, it doesn’t budge. I always give it a good yank after installing. No issues yet.

Someone suggested using a Ram X-Grip Tether. It’s just the rubber spiderweb. Saw a pic with an XT and it doesn’t interfere with the screen at all. About $4.
spike747
Posts: 6
Joined: 19 May 2020 03:51
Canada

Re: Locking on mount doesn't feel like its latching right

Post by spike747 »

I was playing with my Zumo 590 today. Its so much better of a mounting system. Why did Garmin move to this. It feels so cheap. I don't like it. I never had to yank on my 590 to see if it was in there.

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest