The invisible unit

For everything Garmin Zumo 590/595 related
Posts: 8
Joined: 10 Jan 2020 22:49
Location: Out There
Been liked: 1 time

Re: The invisible unit

Post by Blodstrupmose »

Had a chat with tech support today.
They had no clue but were very willing to replace the unit with no cost to me.

Thanks for all the advise guys.
This is a good fourum, I might hang around a bit.
Posts: 908
Joined: 18 Jun 2018 10:14
Location: North Carolina USA
Has liked: 97 times
Been liked: 208 times
United States of America

Re: The invisible unit

Post by rbentnail »

It may not be the device or the cable at all. I went through this when I first tried to connect my then-new 595LM to my Toshiba laptop. It would charge but neither Windows or Base Camp would recognize it as a mass storage device as it normally should. Turns out my laptop has 3 usb ports and only 1 works for the 595. My old Garmin nuvi gps device worked in all 3 so this really drove me batty for a while. In order to connect the 595 I must use that 1 port. Turned out it's the only port a usb connected printer works with, too. I just lucked out and happened to randomly plug the printer in there when I bought it so this never came up before.
Russ B. Zumo 595 & XT
2007 & 2013 USA Yamaha FJR1300A