345LM MTP Mode

For everything Garmin Zumo 345/350 related
Posts: 1
Joined: 31 Jul 2020 08:56
Great Britain

345LM MTP Mode

Post by MT07 »

I tried connecting my 345LM to my motorcycle battery using the garmin cable but the voltage regulator box kept blowing (3 times), always the little capacitor inside is fried.

I have now connected via the USB lead however whenever I stop during a trip and turn the bike off the garmin turns off, when I turn the bike back on the garmin turns on in MTP mode. If I press the power button it either crashes or reboots in MTP mode (frustrating cycle).
If I press cancel to a shutdown and leave the garmin on, when I turn the ignition on it switches to MTP mode.

I have to turn the ignition/power off several times and reboot to get it to power on correctly, sometimes it reverts to MTP mode 5 mins into my resumed trip.

I have removed the data wires in the USB cable so there is only the 2 power wires going to it.
I have tried the other diagnstic settings for MTP mode to no avail.

It behaves OK on battery only, I can turn on/off without issue.

It always powers on correctly first thing in the morning, only if I turn it off midway through a trip does it not reboot correctly.

Does anyone else experience this and/or is there a trick to reboot it without MTP mode or disable MTP mode??

Thanks in advance.