Zumo 595 Portrait Display

For everything Garmin Zumo 590/595 related
jfheath
Posts: 169
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 42 times
Great Britain

Zumo 595 Portrait Display

Post by jfheath »

I have been playing around with the 595 software on my 590 as an experiment.

2 issues with the newly installed 4.6.0 software for the 595

1 There is no option for changing display to portrait.
2 It is not possible to schedule a date for a trip like you can with the 590.

In both cases, the online manual and the pdf manual for the 595 make no mention of these features, so I am wondering if either feature exists .

Elsewhere, someone suggested maybe a difference between LM versions and non-LM versions.

I am trying to work out what software I am using ( it is 4.6.0) or whether this experiment has an inherent fault.

Can anyone with a 595 take a look and report back please ?

Many thanks

sussamb
Posts: 682
Joined: 23 Apr 2018 13:06
Has liked: 12 times
Been liked: 120 times
Great Britain

Re: Zumo 595 Portrait Display

Post by sussamb »

2. is true of the Drive and recent nuvi line also, can't comment on 1

Hati
Posts: 53
Joined: 25 Dec 2019 22:12
Has liked: 1 time
Been liked: 12 times
Australia

Re: Zumo 595 Portrait Display

Post by Hati »

595 with 4.6 SW version. Portrait mode is under Settings/Display/Orientation. For me this is the same throughout countless updates.

Second issue: you can change departure time in a trip created on the device by selecting the trip, tap the spanner for options and scroll down to "Edit Schedule" where you can change departure time.

jfheath
Posts: 169
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 42 times
Great Britain

Re: Zumo 595 Portrait Display

Post by jfheath »

Thanks Hati.

It looks like it may be software for a different varant. What you said is exactly as the 590 is.

What is the SW version of the 595? Or is that just the software version.?

biz
Posts: 24
Joined: 08 Jun 2018 09:45
Location: Highland Perthshire, UK
Has liked: 4 times
Been liked: 1 time
Great Britain

Re: Zumo 595 Portrait Display

Post by biz »

Hati wrote:
08 Jan 2020 08:12
595 with 4.6 SW version. Portrait mode is under Settings/Display/Orientation.
Not on my 590 running 595 firmware V4.60....

jfheath
Posts: 169
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 42 times
Great Britain

Re: Zumo 595 Portrait Display

Post by jfheath »

biz wrote:
08 Jan 2020 11:18
Not on my 590 running 595 firmware V4.60....
That is exactly the problem I am investigating. I don't know whether it is the software running on a 590 that causes it, or whether the installed software is software designed for a variation of the 595 (particularly since the start up screen doesn't display the model number).

Oddities discovered so far:
No option to orientate the screen display - portrait / landscape. (The manual doesn't mention the option to do this)
Not able to schedule a date for a trip. Only a time. (The manual only describes setting the scheduled time).
No phone icon when a phone is connected.

Not that I am complaining. The update from 3.3 to 4.60 looks quite remarkable and seems to work well otherwise. But still early days.

biz
Posts: 24
Joined: 08 Jun 2018 09:45
Location: Highland Perthshire, UK
Has liked: 4 times
Been liked: 1 time
Great Britain

Re: Zumo 595 Portrait Display

Post by biz »

jfheath wrote:
08 Jan 2020 12:23

Oddities discovered so far:
No option to orientate the screen display - portrait / landscape. (The manual doesn't mention the option to do this)
Not able to schedule a date for a trip. Only a time. (The manual only describes setting the scheduled time).
No phone icon when a phone is connected.

Not that I am complaining. The update from 3.3 to 4.60 looks quite remarkable and seems to work well otherwise. But still early days.
I've no interest in having the portrait display, but I did notice, and was annoyed by, the inability to schedule a trip. Never noticed that there's no phone icon, and as I didn't know there might be, not missed it! :)

User avatar
mzeist
Posts: 72
Joined: 27 Apr 2018 08:52
Location: Zeist, the Netherlands
Has liked: 13 times
Been liked: 17 times
Netherlands

Re: Zumo 595 Portrait Display

Post by mzeist »

jfheath wrote:
08 Jan 2020 12:23
Oddities discovered so far:
you can add to this:
  • When a track is displayed (not the trip log) the device will zoom in fine, but never automatically zooms out again
  • It creates a corrupt "GarminDevice.xml" causing Basecamp to throw an error message upon connecting the 590+5. Basecamp will then not be showing the tracklog, waypoints and other data.
  • GarminDevice.xml also states the device as 'zumo' and not 'Zumo 595' but that only seems to be a cosmetic problem.
  • Another minor problem is the hidden folder '.system' in MTP mode. You can reset the hidden attribute, but after rebooting the 'Zumo 590+5' it's hidden again (I'm quite sure the 590 didn't revert .system back to hidden after reboot).
  • The last 'problem' I noted is that it takes about 45 seconds before the Zumo is shown in Windows Explorer after connecting to the USB port. I think that was much much shorter before the upgrade.
I'm not complaining either, never had the urge to revert back to the 590 firmware (except maybe for the auto zooming not functioning whilst displaying a track). The Basecamp error can be solved by editing a few lines in GarminDevice.xml and make de file read only (except during updates)
Groet, Marcel.
ST1300 - Etrex Vista, 60CS, Co300, SPIII, SP2610, Nuvi760, Zumo660, Or650, Nuvi3590, Zumo590/5, Zumo XT

jfheath
Posts: 169
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 42 times
Great Britain

Re: Zumo 595 Portrait Display

Post by jfheath »

Thanks fir that addition Marcel. Thanks too for the detailed info that you posted for me on the GOSExpert forum. The communication problem is one that I haven't bothered with. It tells me that I cant communicate and then manages to do so !

I hadn't noticed the longer delay connecting to the USB in Windows. It took a while anyway. But it is much much faster to recognise the connection in Basecamp - it used to take a few minutes while it loaded the maps from the Zumo. Now it is almost instant, and shows all of the data for routes that is on the Zumo. So far anyway. So at present, the communication message seems to be cosmetic.

Interesting though - I wanted to revert back to being a 590 yesterday to check something out. The Updater program hung on a long time before it recognised the presence of the Zumo. Previously when installing the 595 software, it found it straight away, and disappeared if I wasn't quick clicking the OK button.

I have not yet noticed the zooming out problem. Do you mean that it doesn't zoom out when navigating a route ? (The magenta line) or do you mean when you have a track displayed on screen ? I sometimes convert my route to a track and display it on top of the route, so that I can tell when the Zumo has recalculated my original route .
Last edited by jfheath on 11 Jan 2020 17:31, edited 1 time in total.

User avatar
mzeist
Posts: 72
Joined: 27 Apr 2018 08:52
Location: Zeist, the Netherlands
Has liked: 13 times
Been liked: 17 times
Netherlands

Re: Zumo 595 Portrait Display

Post by mzeist »

jfheath wrote:
09 Jan 2020 07:29
I have not yet noticed the zooming out problem. Do you mean that it doesn't zoom out when navigating a route ? (The magenta line) or do you mean when you have a track displayed on screen ? I sometimes convert my route to a track and display it on top of the route, so that I can tell when the Zumo has recalculated my original route .
Yes, a track converted from a route. If it is displays a track the Zumo zooms in to 50 m for instance for a corner but will never zoom out again whilst a track is shown. There is a work around, converting a track to a map image, that works great but takes some time.

Basecamp will not show the Zumo until Windows mounts the Zumo drive(s) (shown in File Explore if you like), I'm not sure how longs this takes in MTP mode but in 'Mass Storage Mode' this will take about a minute where the Zumo 590 firmware only took 10 to 15 seconds (from memory)
Groet, Marcel.
ST1300 - Etrex Vista, 60CS, Co300, SPIII, SP2610, Nuvi760, Zumo660, Or650, Nuvi3590, Zumo590/5, Zumo XT

Who is online

Users browsing this forum: CommonCrawl [Bot], flateric and 0 guests