Variety of Waypoint Icons Not Showing Up?

Having Garmin zumo XT problems? there is loads of help and advice in this forum
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

Hi, I'm creating routes in Basecamp for Mac on my MacBook Pro. I'm taking a 20 day trip in which I created 20 seperate routes with waypoints in BC. I named them Day 01, Day 02, Day 03 and so on. Each route has anywhere from 5 to 25 waypoints making sure I stayed under the 31 alerted waypoint limit. I exported all of the routes on my SD card individually by doing the following; Inserted SD card in my MacBook Pro > Opened BC > Highlighted Day 1 > File > Export Day 1 > Chose my SD card > Garmin Folder > GPX Folder > Import. I then installed my SD card back into the XT. I imported them all in which all went fine. I followed up by going into Saved > Select All > Import (Favorites) and imported all my waypoints which all imported fine. I then followed up to see if they're showing up in my route Day 01 in which they did. Here's my dilemma, "All of the waypoints" show as red flags. When creating the waypoints I did choose some red flags but, I also chose motel, food and some other icons in each route. My question is, why aren't those icons on my map or list? I would think they would be since there is so many to choose from in BC. In addition, my list of routes are not in chronological order for some reason. I would sincerely appreciate your help. Thanks, Ray
User avatar
Peobody
Subscriber
Posts: 1462
Joined: 20 Apr 2021 13:33
Location: North Carolina USA
Has liked: 109 times
Been liked: 321 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by Peobody »

Basecamp waypoint icons do not transfer to the XT. On the XT, the starting point is a green flag, the ending point is a checkered flag, and all interim alerting points are orange flags.

As for sort order, there was a recent lengthy discussion about this. What was determined is that any routes that have a departure date and time assigned to the first waypoint in their route will cause those routes to be sorted to the bottom of the Trip Planner list in sequential order based on departure date and time. In your case, if you only place the 20 routes on the XT, you can control their sort order by adding a departure date/time to each one.

This is that discussion: viewtopic.php?t=2769
2008 Honda GL1800 Goldwing
1995 Kawasaki ZG1000 Concours
zūmo XT linked to Cardo Packtalk Bold and iPhone SE.
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

Thank you for your help in explaining the reason to both issues. In regards to icons, too bad Garmins software doesn't transfer "their waypoint icons" to the XT. I'll probably still use them in BC for sorting in my collection list.
As for Garmins sorting strategy, I'm not surprised. They turn some of the simpilist things into a P.I.A. That's quite a discussion you went throught on how to deal with it. For me, I think I'll just keep naming my routes Day 01, Day 02..... to simplify things. Scrolling through my routes in the Trip Planner app of saved trips on the XT, would be much easier. Thanks again for all your help, I sincerely appreciate it. Ray
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

Came across a new problem..... I added a couple more waypoints to my route named Day 9 in BC making it 16 in all. I then deleted the original Day 9 route on the XT in Trip Planner > Saved Trips > Delete Trips > Day 09. I followed up by removing my SD card from the XT and deleted Day 09 in the Garmin folder > GPX folder on my MacBook. At this point, Day 09 is now gone from both, the SD Card and XT.
I then exported the newly edited Day 09 from BC to my SD card in the usual way.... no problem. Inserted the SD card into the XT > Where To > Saved (Favorites) > Import. Checked, those new waypoints are in the list. I then went to Trip Planner > Import > Day 09 and opened it. Those new waypoints are not on the list but, they are on the map. It "list" appears to be reverting back to the original Day 09 for some reason that should have been deleted. Wierd that the new waypoints are on the map but, not on the list. I double checked in BC and all are set as alerted. Is there something I'm missing?
User avatar
Peobody
Subscriber
Posts: 1462
Joined: 20 Apr 2021 13:33
Location: North Carolina USA
Has liked: 109 times
Been liked: 321 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by Peobody »

I don't have a clue as to what would cause alerting waypoints that show on the map to not show in the list. You have probably already tried this but if not, delete that route from the XT and the card and try the transfer and import again.
2008 Honda GL1800 Goldwing
1995 Kawasaki ZG1000 Concours
zūmo XT linked to Cardo Packtalk Bold and iPhone SE.
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

Thanks for your help once again... I did try that a couple times but, I'll give it another try. I'm also thinking about deleting all off the SD card and re-importing them all. Some kind of glitch going on :roll: Thanks again, appreciate it. Ray
User avatar
Peobody
Subscriber
Posts: 1462
Joined: 20 Apr 2021 13:33
Location: North Carolina USA
Has liked: 109 times
Been liked: 321 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by Peobody »

FWIW, I use a process similar to yours, with the following possible difference:

When I export from Basecamp I export only the route and not a List or List Folder. This means that the waypoints are not included in the export, but they are included in the route. During the import process, all waypoints in the route get automatically added to the Saved list in "Where To". This actually annoys the heck out of me because I consider it clutter. I don't need all of them 'Saved' because I will never select one as a destination using Where To. If I ever needed to go to one of them I could start the route in which that waypoint exists and select it as the starting point so why Garmin adds them all as 'Saved' is beyond me.

BTW, If you are going to do a total redo, consider adding a departure date/time to the first waypoint in each route. Having that sort order in Trip Planner makes life a tad easier.

Also, are you familiar with showing a track of a route on the map as way to identify a recalculation change to the route? If not, this is worthwhile if you have the time to learn about it.
2008 Honda GL1800 Goldwing
1995 Kawasaki ZG1000 Concours
zūmo XT linked to Cardo Packtalk Bold and iPhone SE.
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

Peobody wrote: 06 May 2024 14:03 FWIW, I use a process similar to yours, with the following possible difference:

When I export from Basecamp I export only the route and not a List or List Folder.
I do the same... For example; I highlight the route in the left window in BC > File > Export Day 01 > SD card Garmin folder > GPX folder

This means that the waypoints are not included in the export, but they are included in the route. During the import process, all waypoints in the route get automatically added to the Saved list in "Where To". This actually annoys the heck out of me because I consider it clutter. I don't need all of them 'Saved' because I will never select one as a destination using Where To. If I ever needed to go to one of them I could start the route in which that waypoint exists and select it as the starting point so why Garmin adds them all as 'Saved' is beyond me.
I totally feel the same.... Saving them does create a lot of clutter. That should be more of an option than an automatic process

BTW, If you are going to do a total redo, consider adding a departure date/time to the first waypoint in each route. Having that sort order in Trip Planner makes life a tad easier.
I agree.... I will definitely give it a shot

Also, are you familiar with showing a track of a route on the map as way to identify a recalculation change to the route? If not, this is worthwhile if you have the time to learn about it.
I've never done that, I'll have to check it out.
I went ahead and deleted Day 09 again both on the XT and on the SD card. I went back into BC and deleted the two waypoints that weren't showing up as discussed. Upon doing so, one of them had a shaping point under it which doesn't make any sense. I didn't put it there and it wasn't in my route Info list. Anyway, I deleted that as well. I then created a new waypoint and went through all the steps and now it shows up on the XT map list as it should. The other waypoint I deleted and replaced shows as well. Thanks again for all you help.... I definitely learned a few things here today and what to look out for. Appreciate ya! Ray
danham
Posts: 302
Joined: 13 Jul 2018 14:25
Location: Cape Cod, MA
Has liked: 96 times
Been liked: 93 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by danham »

PaulaRay wrote: 06 May 2024 13:24 Thanks for your help once again... I did try that a couple times but, I'll give it another try. I'm also thinking about deleting all off the SD card and re-importing them all. Some kind of glitch going on :roll: Thanks again, appreciate it. Ray
I only had this happen once, and it was a while ago, but if I recall correctly, the cure was to rename the route, not just in BC, but also inside the XML code which makes up the gpx file, and upload it to the XT under the new name(s). You shouldn't normally have to do this, but it seems the XT can hang on to an old version under some unexplained circumstances.

You can edit the gpx file's internal name using any text editor. Here's the relevant XML tag in one of my routes, using TextEdit on my iMac. Scroll down until you see the opening <rte> tag. If there are lots of waypoints, it may be down a ways.

<rte>
<name>Happy Valley Ride - SHP</name>

On my old zumo 660, editing the internal name and adding a number before it would force order in the import list. Haven't tried this on the XT.

-dan
Zumo XT, 660, nuvi 760 and many retired units dating back to the GPS III+
2018 Kawasaki Ninja H2 SX SE
PaulaRay
Posts: 101
Joined: 20 Mar 2022 11:35
Has liked: 74 times
Been liked: 10 times
United States of America

Re: Variety of Waypoint Icons Not Showing Up?

Post by PaulaRay »

danham wrote: 06 May 2024 15:21
PaulaRay wrote: 06 May 2024 13:24 Thanks for your help once again... I did try that a couple times but, I'll give it another try. I'm also thinking about deleting all off the SD card and re-importing them all. Some kind of glitch going on :roll: Thanks again, appreciate it. Ray
I only had this happen once, and it was a while ago, but if I recall correctly, the cure was to rename the route, not just in BC, but also inside the XML code which makes up the gpx file, and upload it to the XT under the new name(s). You shouldn't normally have to do this, but it seems the XT can hang on to an old version under some unexplained circumstances.
That certainly wouldn't surprise me

You can edit the gpx file's internal name using any text editor. Here's the relevant XML tag in one of my routes, using TextEdit on my iMac. Scroll down until you see the opening <rte> tag. If there are lots of waypoints, it may be down a ways.

<rte>
<name>Happy Valley Ride - SHP</name>

On my old zumo 660, editing the internal name and adding a number before it would force order in the import list. Haven't tried this on the XT.
Thanks.... I will give that a shot if I reload all the routes. If I don't, I'll give it a try next time. Appreciate it. Ray
-dan