zumo 390 trip planner problems

For everything Garmin Zumo 390/395/396 related
cachs005
Posts: 2
Joined: 15 Feb 2024 07:01
Malta

zumo 390 trip planner problems

Post by cachs005 »

I have 2 GPS: the Zumo 390LM and the Zumo 396LM. I bought the 396 after the 390 glitched for some minutes when i was on a roadtrip and decided i should have a backup. I usually program my roadtrip on the 390 transfer it to basecamp and then tranfer from basecamp to 396 (reason for using 390 instead of 396 is below).

but first to my current problem: I was programming my 390 with some routes (i got a list of around 40 trips in the trip planner for the upcoming road trip.) My maps are on the memory card so the gps internal memory should be free. Last monday i entered another trip to continue and the trip planner sort of glitched. It won't let me enter more trips (button greyed out), the trips are scrolled endlessly (usually i go from the first one i entered and stops at the last one), now it is repeating all the trips endlessly. Furthermore whn i tried to transfer the trips to the memory card, the gps switches off. I tried to reset it to no avail. Hold the button for 30 seconds to no avail. When i tried connecting it to the laptop via usb it won't come up neither on basecamp nor on garmin express. It's as if it is not recognised anymore. Yesterday it wasn't charging via usb neither so i had to put it on my motorbike mount to charge it. I am painstakingly opening each map planned on the 390 and program it again on the 396 which i the only solution i found not to lose my work. Anyone got any clue on what might have happened to my 390?

Now as to why i use the 390 instead of the 396 to enter my trips. The 390 is more easy. The 396 being more modern doesn't have some of the functions in the trip planner implemented as the 390. First of all i cannot rename waypoints (on the 390 you can) or at least i can't find out how. Another annoying thing is when i am plotting a trip, i usually use the browse method... follow the road and mark a waypoint where needed. On the 390 when i browse it brings me to the last waypoint i entered so i can easily continue, whereas on the 396 it reverts me to the home point and i have to continuously use search (recent destination/history) for the last coordinates/towns i entered then have to scroll all the way through the route until i find the last waypoint and continue from there. Am i doing something wrong on my 396? or is it like that?

Thanks