XT charging & 40% brightness issues

Having Garmin zumo XT problems? there is loads of help and advice in this forum
JS_racer
Posts: 56
Joined: 13 Jun 2020 00:18
Location: Minnesota
Has liked: 6 times
Been liked: 4 times
United States of America

Re: XT charging & 40% brightness issues

Post by JS_racer »

Fxwheels wrote: 23 Feb 2023 16:30
Hopsngrains wrote: 06 Aug 2022 17:44 I may consider another mount idea, using the USB, as when I connect this cable it does charge.
Right.
I had the same set of issues on my bike ST1300 (Pan European). I also got the 40% issue on a rented BMW in Spain and my old backup Nuvi 1450 saved my day.
At home, my solution was connecting the nav via USB cable to a USB 2.0 plug wired to an ignition vires. No power loss issues anymore.
the output of the usb adapter needs to be 2.0a or more, then no issue..
I use it in the car on a dual 2.4a adapter, to usb cable. full charges the gps running up to 17 hours with no issue.
tried it on the bike with a 1a, dim screen after X time , swapped adapter on the bike to a 2a, perfect.
User avatar
Peobody
Subscriber
Posts: 1462
Joined: 20 Apr 2021 13:33
Location: North Carolina USA
Has liked: 109 times
Been liked: 321 times
United States of America

Re: XT charging & 40% brightness issues

Post by Peobody »

JS_racer wrote: 04 Mar 2023 15:32 tried it on the bike with a 1a, dim screen after X time , swapped adapter on the bike to a 2a, perfect.
Interesting. I had this problem while using a dual 2.4 amp cigarette lighter adapter on my Goldwing. I had to wire the Garmin mount. I also had the same problem when trying to use the XT in my car (2.1 amp cigarette lighter adapter). I have since learned about charging (power only) cables and have purchased one for the car but have not tested it.
2008 Honda GL1800 Goldwing
1995 Kawasaki ZG1000 Concours
zūmo XT linked to Cardo Packtalk Bold and iPhone SE.