A simple but a very specific question….

For everything Garmin Zumo 660/665 related
Posts: 2014
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 232 times
Been liked: 534 times
Great Britain

Re: A simple but a very specific question….

Post by jfheath »

Gidi Ferder wrote: 22 Jan 2022 22:00 Ok, you asked for it 😆
Oh, goody - I've just come in from stage one of the bike service. (I have to do it in small steps these days). I wondered what I was going to do next :lol:
Gidi Ferder wrote: 22 Jan 2022 22:00 Referring to your reply by no.
Gidi Ferder wrote: 22 Jan 2022 22:00 1. I know that and I saw it can be done. What I’m asking is if copying old favorites that were saved on older maps before the maps were updated, will not corrupt the location. Can I rely on them?
Yes. The data i stored between metatags in the gpx file that will be transferred.
A short example:

<wpt lat="54.3044114112854" lon="-2.199411392211914">
<name>Crown Hotel</name>
<cmt>Crown Hotel</cmt>
<desc>Crown Hotel</desc>
<sym>Flag, Blue</sym>

In between the <wpt > and the </wpt> there can be many other metatags included as part of the waypoint.
So not only is the name and location transferred but all of the other saved information that can be included with a waypoint - like address, post code, elevation, phone number.

To answer your question - it has absolutely nothing to do with the map - other than the fact that latitude and longitude are understood by all maps.

I transfer my routes, tracks and waypoints to completely different mapping software on ewhich I have the very detailed Ordnance Survey maps of the UK to a scale of 1:25,000. They all transfer precsisely. I also use maps from other countries.

Now - if the maps weren't drawn properly in the first place ...... that is different.

Gidi Ferder wrote: 22 Jan 2022 22:00 2. If this answers the above question, please explain what type of settings changes should be made?
I don't know the answer to that - 'cos I don't have a 660 any more. But I know why I made the comment:

There is a difference in devices in the way that they make their USB connection.
The two different methods in question are Mass Storage Mode and Media Transfer Protocol.

Mass Storage mode is how you see your disk drives in a file explorer on your computer - with a drive letter. You can read from thema nd write to them apparently simultaneously. And if it is a plug in device using a USB cable, you MUST remember to close the connection at the computer before you unplug it - otherwise stuff that you think you have saved, may still be held by the computer in a memory cache, and never transferred to the plugged in device.

Media Transfer Protcol is different. It does away with the need to formally 'eject' the device at the computer before it is unplugged. It doesn't have a drive letter - it appears as a named device. Liek 'Zumo'. Everything gets writeen straight away. The down side is that you cannot edit a file on the device. You can read it into a program on the computer, alter it and then save it back. But you cannot edit it in place on the attached device.

I may be wrong about this - its been a long time since I had a 660 in my hands - but I believe that by default when it is plugged in to the computer, the 660 appears as one or two drive letters - depending on whether or not it has an SD card. The XT always appears as Zumo XT - never with drive letters. Basecamp will still read my 590 when it is set to Mass Transfer rather than Media Transfer Protocol.

The point that I was making is that there may be hiccup in the process. There may not. But if it crops up it is easlily solvable.

Gidi Ferder wrote: 22 Jan 2022 22:00 3. So waypoints are those locations that I’m saving and integrate them in the routes.
Yes. - You go it.

But waypoints can be saved for future use too. You don't have to put them into a route. Suppose you are planning a touring trip with some days off. You research some possibilities, create Waypoints for all of the possible venues to visit, and transfer them to you Zumo. These points don't appear in any routes yet. But on one of your days off, you decide to go and visit one of them.

Where To ? -> Favourites -> Choose the location from the list that you saved.
Gidi Ferder wrote: 22 Jan 2022 22:00 Via points are the points I’m marking with mouse while planing? Correct?
Or at least, not necessarily.
I don't know what they are. Not becasue I don't know, but becasue I cannot see what you are doing. So best to just call them route points for now.
When you drop a route point onto the map with a mouse click, it may just happen to land on a known location. Even if you cannot see it.
If it does, it is likely to have been placed as a Via Point. If it is in the middle of nowhere it is likelyt o become a shaping points.
I wouldn't worry about what type of point it is until later. The only way that you can tell and change the type of point is in the route properties dialogue box (double click the route or the route name) If the route point is in black, it is a Via. If it is ingrey with the words (won't alert) in brackets after it, it is a shaping point. The points that you created as Waypoints and used int he route will aslo display in here, but you cannot tell from this list whether or not they are Waypoints.

In the BAsecamp windows, there is a pnae, bottom left, in which the route name will appear. If a route point appears in the same pane, with the route, then it was created as a Waypoint. It is the only way that you can tell !! - Except in the route properties box where you set alert and don't alert - there is a PLUS button at the side. If you click on that it allows you to add a new route point from those that you have created. It lists only the Waypoints. That is actually the only way that I know of to get one of your own saved Waypoints into a route after it has been created.

If you have some Waypoints saved, you may decide to create a route using some of them.
You may then add some additional points using the insert tool.
At this point, whether a point was saved as a Waypoint or simple dropped onto the map with a mouse click is irrelevant. ALL of thse points now are treated as either Shaping Points or Via Points.

Shaping Points do not alert you as you approach or arrive. Via Points do.
Any route point including one that was created as a Waypoint, can be made into a Shaping Point
Any route point (including those created as a Waypoint) can be made into a Via Point (Waypoints default to being Via Points, but can be changed).

Gidi Ferder wrote: 22 Jan 2022 22:00 Regarding announcements I have those turned off so I can’t tell what and when my 660 anounnces.
Ok - so there is another big difference between Via and Shaping Points.

On the 590 and later (devices with the trip planner app), when you start a route you are asked to select your next destination. Garmin seem to use the word 'Destination' to mean 'Via Point'. It then lists all of the Via Points in the route.

Put this into context. On the 660 you may have had a route which had a start point some miles away. It would ask if you want to navigate to the start. Say yes, and it takes you there, and when you get to that point, it says you have arrived and stops the navigation. Which was a real pain. In fact if you said no to that question, and made your own way to the start, as soon as you got there it would start navigating the route without having to do anything.

The XT (and 590, 595, 39x) creates routes like the 660 - which are separated by Via Points. The orange flags. In between the Via points are a number of shaping points, and they behave exactly like a complete route in the 660. When you approach the next Via Point, it alerts you - like the 660 alerts when you are approaching the end of a route. But the XT then continues automatically to the next section.
When you start a route and it asks to select you next destination - it is asking at which Via Point do you want to start the route. It will take you there in its own way - just like the 660 - but then it will continue with the rest of the route as you planned it.

Just like the end point on the 660 - you have to visit it before it finishes the route. The XT you have to visit the Via Point before it will start the next section.

The shaping points in between - just like the 660 intermediate points - you can miss them out. It will try to get you to visit them, but the moment you joint he magenta route, it carries on navigating you forward as if nothing had happened.

You can tell if the Zumos are saying anyhting - the direction on the map shows up as a wide white arrow on top of the magenta route, and the text of what is being spoken is reproduced across the top of the screen.
Gidi Ferder wrote: 22 Jan 2022 22:00 And a new one:
I just opened the map info on my 660 and for some reason I have three map files with check boxes:

1. CN Europe NT 2021.10
(1) ALL
2. CN Europe NT 2021.10 BASIC 3D
3. CN Europe NT 2022.10
(1) Tirane, shqiperia, andora Graz

I remember that during the last update there was not enough memory space for the full map if Europe. Was I suppose to delete the 2021 map? And the basic 3D. Shouldn’t it be updated as well?
I don't remember using 3D maps on the 660. I may have, but I've had the 590, 595 and XT since then. But not all maps are updated at the same time, so you may get different version numbers for different maps.

I remember running into memory problems and maps with the 660. If we were going abroad, I would delete all of the maps and using MapInstall (Express didn't exist at the time), I would install just the areas of the maps that I needed for the trip - having deleted all of the others. Deleting isn't just a case of unticking them, you have to find the appropriate file on the Internal Stoarage. Basecamp can help with this - it will show the maps that are installed and if you click on the map on the Zumo - in the left hand pane. It gives all of the map details in the pane underneath.

I don't know if Mapsource does this as well.

There are usually three files associated with each map. All have the same name but fifferent extenions.

So there might be (say)
D6210190A.unl (unlock file)

Today, I discovered something really important. I found another way that doesn't work.
Gidi Ferder
Posts: 13
Joined: 17 Jan 2022 21:08
Been liked: 2 times

Re: A simple but a very specific question….

Post by Gidi Ferder »

I think I have enough info to start fiddling with Base Camp.
Many to apply some of your tips I will definitely need to read them on the fly step by step.
There are more things bothering me such as the fact that I couldn’t update the whole (all) of Europe on the 2022 map update. Garmin express made me choose part it the continent.
At the moment I have 3 map files on my 660.
CN Europe NT 2021.10
CN Europe NT 2021.10 Basic 3D
CN Europe NT 2022.10
(1) and 5-6 countries 😎
I’ve got all three checked and all 3 saving methods you suggested worked. I have three routes on my devise that by checking their preview match perfectly to the planning on my PC.
I don’t understand how to erase maps from the devise. My guess was to erase the 21 map and than reinstall the last updates 22 map (all). Currently Garmin express claims my devise is loaded too muck to take all of Europe

On my computer BaseCamp allows me to check just one map and I have the 2022 of all of Europe checked
Hope you can continue to educate me
Posts: 1660
Joined: 23 Apr 2018 13:06
Has liked: 271 times
Been liked: 343 times
Great Britain

Re: A simple but a very specific question….

Post by sussamb »

How did you install the maps to your device? Express should have automatically deleted the older maps.

You can certainly manually delete them and should do so as multiple maps covering the same area can cause issues. You will find the map files either in the Garmin folder or a folder named Map. You're looking for large .img files, normally one would be named gmapprom.img and the other gmapsup.img but depending on how the map files were installed names may be different.

If you're new to BaseCamp, as you talk about fiddling with it, this tutorial may help:

Gidi Ferder
Posts: 13
Joined: 17 Jan 2022 21:08
Been liked: 2 times

Re: A simple but a very specific question….

Post by Gidi Ferder »

Thanks again
I did update the maps using Garmin express. I expected the program to clean the devise from older maps but it did not happen.

Should I reinstall the 660 maps? Or even better, to clear it to “out of the box” state and start fresh. I tried to use Garmin Express. I did:
1. connect the 660 to computer
2. run Garmin express
3. clicked on the “Zumo 660”

but it looks like the “map options” menu doesn’t exist
Any idea?
In any case I’d like to know if there is a way to erase the maps from the Zumo.
Posts: 2014
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 232 times
Been liked: 534 times
Great Britain

Re: A simple but a very specific question….

Post by jfheath »

I am hesitating with an answer to this one.

That is because I do not remember whether the 660 required you to enter cerain codes in order to unlock the maps.

But I think with the 660LM model, you can just download them using Express, but cannot be sure.

The link to load the maps to different places - I seem to remember it being hidden away somehwere - perhaps scrolling down the screen, when it wasn't obvious that there was more information to display. But Express has changed so much since I used it with a 660.

Regarding deleting the maps - I wouldn't do that yet, in case they are needed.

The pages from Garmin say

You can have up to 32Gb on an SD card in the 660
It must be formatted as FAT32 - some of the larger cards come formatted as XFAT
If there isn't enough room in internal memory, for the map then it will offer to install on the SD card.

There's a whole thread on this issue with a lot more up to date information here:

And some useful help pages from Garmin below.

https://support.garmin.com/en-GB/?faq=U ... pgAhUUCqp7

https://support.garmin.com/en-GB/?faq=b ... KUAt8x67J7

We can tell you how to delete the old maps later. There wasn't ennough room for the whole of Europe when I had a 660, and the maps usually get bigger, not smaller over time so there wont be room either. If you want the whole of Europe, you need to use the SD card.

I just made sure I installed the relevant sections before going to Europe. Accessing internal memory is faster than accessing an SD card for the Zumo, and the 660 was always a tad slow when its memory was getting a bit full.

Today, I discovered something really important. I found another way that doesn't work.
User avatar
alan sh
Posts: 93
Joined: 23 Apr 2018 14:40
Location: Rochdale
Has liked: 5 times
Been liked: 26 times
Great Britain

Re: A simple but a very specific question….

Post by alan sh »

I have the 660LMT (actually, I have 3 of them) and I download maps using Garmin Express. No codes to enter.

Owner of 3 Zumo 660's, one 346 and 2 bikes
Posts: 2014
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 232 times
Been liked: 534 times
Great Britain

Re: A simple but a very specific question….

Post by jfheath »

Thank you Alan

Today, I discovered something really important. I found another way that doesn't work.
Gidi Ferder
Posts: 13
Joined: 17 Jan 2022 21:08
Been liked: 2 times

Re: Many thanks!

Post by Gidi Ferder »

I would like to thank everyone who participated in response to my post. Special thanks to you jfheath!!!
You were a key player in my struggle with the relations between BaseCamp and the 660.
Thanks to you, jfheath, I was Able to load routes perfectly from BaseCamp. It’s that issue with lack of shaping points that makes the machine go crazy.
Of course there is a “but”:
1. My old 660 has 4GB internal memory. My CD card is 32GB. But when hook the 660 to the computer I could not see the memory room of the card.
2. Garmin express worked like shit. I installed the map via BaseCamp and mapinstall. The bar showed that I have 6GB(?!). So I could not load all of Europe and had to settle for most of it.
3. At the moment BaseCamp shows that my internal memory is almost full. Looking at file explorer on my computer I see that the memory card has 29 GB free. That means that the map sits on the Zumo and not on the card.

Albite all those “buts” I can work freely. I am saving the routes and favorites on the card (which makes them come up slow). I guess my old Zumo is having problems communicating with more advanced technology. I changed the old CD to new one class 4. Maybe that’s the reason for display problems.
I need to plan 5 tours. 1400 kn each. The first one goes out end of April. I will report the results on the road.

Again many thanks jfheath!
Best regards
Gideon ferder
User avatar
Posts: 62
Joined: 10 Jul 2018 07:21
Has liked: 7 times
Been liked: 18 times
Great Britain

Re: Many thanks!

Post by Les »

Gidi Ferder wrote: 03 Feb 2022 13:07 That means that the map sits on the Zumo and not on the card.
I also use Mapinstall to load the maps onto my 660, Express always telling me there in no space, I have a 32gb card.

When opening Mapinstall, make sure that you select 'memory card' in the little box where it says 'send to', this works for me.