Hi from Cumbria, UK

Feel free to join up and say hello here.
mhirst121
Posts: 2
Joined: 23 May 2021 18:13
Great Britain

Hi from Cumbria, UK

Post by mhirst121 »

Hi all, I have recently purchased the Zumo XT for use on my Kawasaki Ninja 1000SX for trips. I have set up the unit and updated and had it out for a test ride. NOT GOOD. Do not think I will be keeping this long and will probably sell at a great loss. You would think at the price point of this even the basic things would work as expected, or am I just being too critical.
Regards,
Martin H
sussamb
Posts: 1325
Joined: 23 Apr 2018 13:06
Has liked: 118 times
Been liked: 257 times
Great Britain

Re: Hi from Cumbria, UK

Post by sussamb »

Well perhaps explain the issues you're having in the XT forum as there are many here who can help you out :D
mhirst121
Posts: 2
Joined: 23 May 2021 18:13
Great Britain

Re: Hi from Cumbria, UK

Post by mhirst121 »

Thanks, I will put up a post at a later date once I can say for certain what is happening. I think most of the problems are software related and when you try and follow someones advice and direction it turns out that that my unit cannot do it. Biggest problem I am having at the moment is mapping and the routes it plans.
Stu
Site Admin
Posts: 747
Joined: 22 Apr 2018 21:38
Location: Hull, UK
Has liked: 330 times
Been liked: 162 times
Great Britain

Re: Hi from Cumbria, UK

Post by Stu »

Hi @mhirst121 welcome to the forum

I would start a new thread as you have said with all your issues you are having and I am sure someone will help you out

It might just be a case of a wrong setting somewhere

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests