Weather Radar not "Playing" when loading

For everything Garmin Zumo XT related
cr0100
Posts: 51
Joined: 21 Apr 2020 16:59
Has liked: 2 times
Been liked: 12 times
United States of America

Re: Weather Radar not "Playing" when loading

Post by cr0100 »

I finally heard back from Garmin, and their response sucks.

"Hello,

Thank you for contacting Garmin International. After reviewing the issue you reported with the weather radar not animating, we've determined this functionality won't change at this time. However, if it is changed in the future, you will be notified via email."

My response to them:

"What a TERRIBLE response.

A feature is deactivated without notice, you're asked about it, and your response is "too bad".

Color me highly disappointed."
jfheath
Posts: 637
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 36 times
Been liked: 163 times
Great Britain

Re: Weather Radar not "Playing" when loading

Post by jfheath »

It might be to do with rules and regulations.

Here in the UK we have this:

Viewing a screen
Legislation states that no person shall drive or cause or permit to be driven a motor vehicle on a road if the driver is in such a position as to be able to see, directly or by reflection, a television screen or similar apparatus except one showing information:

  • about the state of the vehicle or its equipment e.g. screen warning lights;
  • about the location of the vehicle and the road on which it is located e.g. some GPS tracking devices;
  • to assist the driver to see the road adjacent to the vehicle e.g. reversing cameras; or
  • to assist the driver to reach their destination e.g. sat navs .



Elsewhere I have seen reference to still images conveying information as being acceptable. But it is difficult to tease out from legal papers.

And this is just a possible explanation - as the animated version works when I use the device in my hand. But its only a cycle of the last 3 hours I think.
ST1300A9 - Currently: Zumo 590/5 and Zumo XT - Previous: Zumo 550 and Zumo 660.
BTM03 module to provide Bluetooth link to Autocom. XT paired up to Android Smartphone
Clammy
Posts: 2
Joined: 25 Nov 2021 00:51
Has liked: 1 time
Been liked: 1 time

Re: Weather Radar not "Playing" when loading

Post by Clammy »

Hey all, new to this forum. Found you while searching for a solution to this issue.

I have been after garmin for MONTHS regarding this issue. I have called them, and opened formal cases, etc... I last talked to a CS rep a couple of days ago, and was finally told the reason they disabled the weather animation while in motion: some "engineer" decided it was a "safety issue" :roll:

The CS rep told me that if they get a lot of complaints, they're more likely to change it back.

For me, this is EXTREMELY frustrating, as one of the big reasons I decided to go with the Zumo series is the animated weather radar that has allowed me to route around dangerous/bad weather (I've been using this feature, for years, since the 66x series).

By removing the animation in motion, they've rendered the feature virtually useless. To me, the "safety issue" reason is ridiculous. It's a lot LESS safe to have to pull over on a busy highway to see which way the weather pattern is going, and then have to merge back. The fact that everything else on the XT animates while in motion, we can fiddle with the mp3 player, settings, apps, etc... all while we're moving also shows how ridiculous a reason that is. Plus, the weather animates on my DriveSmart 55 car GPS, while in motion. :roll:

I encourage everyone to swamp them with complaints, and keep on complaining. I told the CS rep straight up that they would be hearing fro me regularly until they fix what they broke, and that I would be encouraging as many others as possible to complain to them as well.

My currently open case number is: PSC-202996 if anyone wants to add themselves to it.

Cheers!
:twisted: :twisted: :twisted:
Last edited by Clammy on 25 Nov 2021 01:04, edited 1 time in total.
cr0100
Posts: 51
Joined: 21 Apr 2020 16:59
Has liked: 2 times
Been liked: 12 times
United States of America

Re: Weather Radar not "Playing" when loading

Post by cr0100 »

Funny you should mention that case number.

Here's the subject line in my email from Garmin:

Garmin zumo XT - Weather Radar not animating (PSC-202996) << Ref: 20722650K1 >> <Q#:1000351>
Clammy
Posts: 2
Joined: 25 Nov 2021 00:51
Has liked: 1 time
Been liked: 1 time

Re: Weather Radar not "Playing" when loading

Post by Clammy »

cr0100 wrote: 25 Nov 2021 20:47 Funny you should mention that case number.

Here's the subject line in my email from Garmin:

Garmin zumo XT - Weather Radar not animating (PSC-202996) << Ref: 20722650K1 >> <Q#:1000351>
Ha! Small world! The numbers between the << >> are referring to the other case I had open, to which I received the exact same response, verbatim, as you did!

We have to keep hammering them.

Cheers!
:twisted: :twisted: :twisted:
cr0100
Posts: 51
Joined: 21 Apr 2020 16:59
Has liked: 2 times
Been liked: 12 times
United States of America

Re: Weather Radar not "Playing" when loading

Post by cr0100 »

Damned lawyers. I suspected that the animation stopping was not a bug, but a "feature". I'm none too hopeful about getting it back.

Who is online

Users browsing this forum: Bing [Bot], CommonCrawl [Bot] and 1 guest