BT Connection of my Galaxy to my 590

Got any questions about Audio, Headsets and Earplugs then please use this section.
MSTOCK27370
Posts: 47
Joined: 05 May 2020 13:02
Has liked: 4 times
Been liked: 7 times
United States of America

BT Connection of my Galaxy to my 590

Post by MSTOCK27370 »

When I ride, I prefer to focus on the road and the ride. I'm not knocking it if you like to listen to music or take calls, but that isn't for me.

However, if the tech allows for it, I would like to be alerted when I get a call on my phone. I don't want to answer the call, but if the call is from my wife, I would pull over and check for a voice message or call her back. I carry my phone in a jacket pocket, with a unique ringtone for my wife's phone. But it's difficult to hear the ringtone when at speed. I'll occasionally hear it if the call happens when I'm slowing for a stop or intersection turn. Keep in mind this isn't for a "pick up milk" phone call, the call would be health related.

I tried to connect my Samsung Galaxy phone to my 590, and they paired up but not for phone calls, just for music. There was some message about the phone connection failed.

I've read the "Zumo 590 and Bluetooth" document. That doc says that you have to follow a specific process to get the BT connection to work. I'm ignoring the headset pairing and just trying to pair the phone. Is this the problem? Do I have to pair up a bluetooth headset first?

Help is appreciated.
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

Stu
Site Admin
Posts: 413
Joined: 22 Apr 2018 21:38
Location: Hull, UK
Has liked: 176 times
Been liked: 82 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by Stu »

You have to pair a headset otherwise it won't allow calls :)

MSTOCK27370
Posts: 47
Joined: 05 May 2020 13:02
Has liked: 4 times
Been liked: 7 times
United States of America

Re: BT Connection of my Galaxy to my 590

Post by MSTOCK27370 »

Stu wrote:
04 Jul 2020 21:22
You have to pair a headset otherwise it won't allow calls :)
Thanks for that. Any suggestions? Remember that I don’t really care about making calls, or talking or listening to music. What headset can I pair up without a big investment?

Would an inexpensive BT earbud set get the phone working or would it have to be a set with integrated mic too?
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

Stu
Site Admin
Posts: 413
Joined: 22 Apr 2018 21:38
Location: Hull, UK
Has liked: 176 times
Been liked: 82 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by Stu »

That's not really something I can answer as I use the cardo packtalk bold which is a bit pricey for what you're after

I can't see why a cheap one wouldn't do the job though

jfheath
Posts: 196
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 44 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by jfheath »

If you don't intend to make / receive calls, forget about the headset. Just pair the Galaxy. But you need to get an app on your smartphone in order for it to talk to the Galaxy for othe features. ... Garmins Smartphone Link. It is mentioned in the document, but it is easy to miss. Ignore that. Read on here........

Excellent idea outlined below, but unfortunately, as @Stu kindly pointed out, the Zumo 590 does not receive notifications from the smartphone.
But these instructions work just great for a 595. I keep switching my 590 back and forth between 590 v3.3 software and 595 v4.60 software. Easy to do, but potentially fraught with danger. I should have switched mine back to a 590 to test it before I wrote this, but made an assumption.... Dangerous things, assumptions.

I have posted an answer in a separate post that will work. And this time I tested it first rather than remembering something incorrectly.


You don't need to have a headset in order to receive a notification from your smartphone - but if you don't have a headset nothing related to normal phone calls will come through.

I did a couple of experiments. Certainly a complete BT headset works - as described inthe document I produced that you have seen.
Headphones (no mic) does not appear to work - I don't have a set without a mic, but I tried it on a BT speaker.


So how about using other notifications instead of a phone call.

Get your wife to text you instead !!

This will do exactly what I think you want -> ie pop up a message on the Zumo screen, so that you can stop and call her.

If you have Garmin's Smartphone Link App loaded into your Galaxy (free from the Google Play App store). Install it and run it. You will need to give permissions for various forms of access to your phone.
687309.png
631993.png
On the Samsung Smart Phone Settings->Notifications->Smartphone Link->Show Notifications - turn it on.

You can get tot he same thing with Settings->Apps->Smartphone Link->Notifications->Show Notifications - turn it on.

In both cases turn on the other switches as appropriate. Today when testing, all of them were on.

My Bluetooth Device Options showed
635787.png

It took a while to get the bottom two to report correctly. Restaring the Zumo solved the Smartphone Link issue.
Allowing Notifications for the Smartphone Link on the Galaxy solved the other.

I sent a text to the Galaxy.

The Zumo popped up a screen with the some of the text and two large buttons. OK and View.
If I tapped OK, the message was dismissed.
If I tapped View, the whole message was displayed and another two large buttons. Dismiss and Play.
Play read out the contents of the message on my radio - the BT device currently connected.
647254.png
647918.png
Sorry - my Zumo is set up with the 595 software at present, but I have compared the screens with the document I wrote a while back and they are very similar.


nb Smartphone Link continues to run in the background. If you want it to stop, you need to force a stop
Settings -> Apps->Smartphone Link->Force Stop.

With that Smartphone link set up you can also get traffic and road work notifications (not so brilliant), delays ahead (pretty good) and live weather radar info - either as cloud/sun/rain icons or as colour shading on the map - excellent.


Hope that helps.

John
You do not have the required permissions to view the files attached to this post.
Last edited by jfheath on 06 Jul 2020 11:06, edited 2 times in total.

Stu
Site Admin
Posts: 413
Joined: 22 Apr 2018 21:38
Location: Hull, UK
Has liked: 176 times
Been liked: 82 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by Stu »

@jfheath the 590 doesn't allow the notifications like the 595 does

MSTOCK27370
Posts: 47
Joined: 05 May 2020 13:02
Has liked: 4 times
Been liked: 7 times
United States of America

Re: BT Connection of my Galaxy to my 590

Post by MSTOCK27370 »

Great responses from both of you. Thanks.

I will pick up a small headset and try to get the headset and then the phone paired up and working with my Zumo 590. I’ll update the thread once I get this done.
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

jfheath
Posts: 196
Joined: 19 Oct 2019 16:17
Location: West Yorkshire, Uk
Has liked: 4 times
Been liked: 44 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by jfheath »

Stu wrote:
05 Jul 2020 15:13
@jfheath the 590 doesn't allow the notifications like the 595 does
Oh, tish. Thanks @Stu . I have Pm'd the OP.

I will leave that post there - suitably modified with a heading for 595 only. Its good information if only I had applied it to the correct machine. I should have switched my device back to a 590 to check. I have too many different Zumos in my head. Thanks for spotting it.

Best solution then is to get BT headphones and mic. As long as it is turned on, and paired, a message will pop up on the screen when the call is received - with a choice of ignore or answer. The headset can be in a pocket if needed - in which case automatic answering would need to be turned off at the Samsung. 3 dot menu from the phone keypad->settings->answering and ending calls.

MSTOCK27370
Posts: 47
Joined: 05 May 2020 13:02
Has liked: 4 times
Been liked: 7 times
United States of America

Re: BT Connection of my Galaxy to my 590 UPDATE

Post by MSTOCK27370 »

Added a mono-headset and the phone (Galaxy A10E) now pairs up with the Zumo 590.

With the phone paired up to my GPS I am able to get what I was trying for. Incoming calls display on the Zumo screen. I haven't tried riding with it yet, but I intend to place the headset in my pocket.

I did test everything in the house, and a couple of items popped up.

Incoming call display - only displays the incoming phone number, not the name of the caller. I went to the Aoos area for the phone and the contact list from my phone doesn't appear. The user manual says that not all phones support this feature. Any thoughts?

I know I said I don't want to make or take calls. When testing the headset and phone links, I received a test call. When I answered the call, the caller could hear me, through the headset mic, but I could not hear the caller. I have, phone, navigation and media all turned ON. I can hear clicks through the headset when I press the options on the screen, and I can play an MP3 song through the headset. Just can't hear the phone call. Thoughts?
Michael S.
Trinity, North Carolina
Zumo 590LM, 450, 550 BMW R1100RT, R100, R60/6

Stu
Site Admin
Posts: 413
Joined: 22 Apr 2018 21:38
Location: Hull, UK
Has liked: 176 times
Been liked: 82 times
Great Britain

Re: BT Connection of my Galaxy to my 590

Post by Stu »

@MSTOCK27370 go into the settings for Bluetooth on thephone and click the share contacts button and the names will display

Who is online

Users browsing this forum: No registered users and 0 guests