Navigator VI Sena Dance

For everything BMW Navigator VI related
Post Reply
mad2ride
Posts: 3
Joined: Tue May 15, 2018 7:29 pm
United States of America

Navigator VI Sena Dance

Post by mad2ride » Wed Oct 09, 2019 6:11 pm

I’ve had my Navigator VI for over a year now and had it paired to my Sena S20 (original not EVO) for that time. It is mounted on my S1000RR so there is no support for it past the electrical plug.

My main reason for upgrading from the Zumo 660 was so I could access and control the media on my phone which is a Galaxy Note 8.

I have run through all the combinations of pairing the phone to the navigator then the headset and first the headset then the phone. I find that the best way to get it to work is to turn on the headset then once I hear “Hello” turn the key on to get power to the GPS.

I can get it to work for a while where whatever is playing on the phone plays over the headset. However it will stop working where I can start the media on the phone but I have no control through the Sena or the Navigator. If you go to the media app the skip and play/pause buttons are greyed out.

Sometimes if I go to the bluetooth control and un-check all the boxes on the phone then recheck them it will work but other times it doesn’t help. I can shut off the GPS, shut off the Sena turn them back on again and it still doesn’t correct it.

When it all goes pair shaped I need to soft reset the GPS by holding the power button in until it does a soft reset.

I sometimes get a week or more worth of riding in but other times it may only work properly once. I’ve just been going with it. Just figuring that’s what I need to do.

I ride my bike almost every day and I’m getting a little tired of this. I would abandon the Sena for another model or even brand. I’m not going to change headsets until I know that it is the headset that is the weak link and not the Navigator VI.

If someone has a definitive fix for this I would be grateful but I suspect that this is what I am stuck with. In that case I guess this is just a bit of a rant.

kebo
Posts: 8
Joined: Mon Apr 23, 2018 6:05 pm
Slovakia

Re: Navigator VI Sena Dance

Post by kebo » Fri Oct 11, 2019 8:47 pm

I have NAV VI, iPhone 6 and Cardo Packtalk Slim. IPhone paired to NAV Vi, Packtalk paired to NAV VI. I do not follow any special order for pairing, all works fine.

Post Reply