Page 1 of 3

The invisible unit

Posted: Fri Jan 10, 2020 11:01 pm
by Blodstrupmose
Hi All.

New here, normally i hangout over on the ADV Rider forum.
Santa was kind to me this year and i got a new 595 LM. Time to play around so i charged it up, downloaded the latest GARMIN EXPRESS and connected the unit.
It is fully charged and connected with the data cable that came with the unit (i have tried other cables with same result )
However EXPRESS does not recognise the unit, after pressing the " + " sign the liitle wheel in the top lift corner just continues to spin. After a couple of minutes it says "could not recognise unit" and stops.

I have an older zumo 660 that works perfectly !!!

What am i doing wrong ??

Getting a bit desperate as i was going to start creating routes in basecamp for trip this summer.

Hope you can help.

Re: The invisible unit

Posted: Sat Jan 11, 2020 8:26 am
by sussamb
Does your computer recognise it? This is Garmin's FAQ that may help, it also may take a few minutes the first time for your PC to recognise it, so set Express to start when a device is connected. ... =noProduct

Re: The invisible unit

Posted: Sat Jan 11, 2020 5:29 pm
by jfheath
There are cables that will charge the device.
There are cables that will transfer data
There are cables that will do both.

Maybe the cable that came with the unit was for charging only ? Although the one that came with my 590 does both. Its a little short for my liking so I bought a 'charge and synch' USB cable from Tescos. I don't know type of connector it is on the end. I took mine in to compare it to make sure that I got the correct one.

Re: The invisible unit

Posted: Sat Jan 11, 2020 7:24 pm
by Blodstrupmose
Hi Guys

Yes i am using the short one that came with the package, but i have also tried a mini-usb i had lying around.
Think i will got the local shop and try a 3rd cable. You never know.

Re: The invisible unit

Posted: Sat Jan 11, 2020 7:37 pm
by sussamb
Have you tried what I suggested, the FAQ and allowing Express to start on its own when you connect your Zumo?

Re: The invisible unit

Posted: Sat Jan 11, 2020 7:51 pm
by Stu
Try installing the garmin usb drivers?

does the computer recognise when you plug it in?

Re: The invisible unit

Posted: Sun Jan 12, 2020 9:38 am
by Blodstrupmose
Garmin USB drivers installed, still no luck.

The unit is not recognised at all. No magic "ping" when it's plugged in.

Thanks for all the help.

I think i will get the new cables, give it a last shot and then it's a recall.

Re: The invisible unit

Posted: Sun Jan 12, 2020 12:04 pm
by sussamb
Note you may need to wait to get the magic ping, it can take up to a few minutes to be recognised by Windows, are you leaving it long enough? Is Express set to launch when it detects a device? If not set it so it does, then close it. Now plug in your device and wait ...

Re: The invisible unit

Posted: Sun Jan 12, 2020 1:14 pm
by jfheath
Sorry - I forgot that this unit was brand new.

The cable should be working if it is new.

Just found this post here - similar problem Turned out that the USB port wasn't providing enough power to the Zumo and plugging it into a powered USB port solved the issue. ... -p/6630662

Assuming that you have access to one.

One other thought. Long shot though, and I only mention it 'cos it happened to me yesterday. I had been fiddling with my 590, plugging in the USB, transferring stuff to and from Basecamp, disconnecting the USB. Repeat. etc.
Then suddenly it stopped working. I thought I had broken it. Eventually I gave up and started to initiate the tried and tested solution to everything that goes wrong with a computer - close I all down and restart it. As I closed down each of the Windows, basecamp there was a warning message saying that Basecamp couldn't communicate - and it was waiting for me to say Ok - and was actually preventing the Zumo or the computer USB port from communicating until I pressed OK. Instead of closing down windows, I closed down Basecamp, and it worked just fine.

Talk with Technical support. If they think it needs to go back, they will give you a returns number. As soon as they get your model they will send another out literally by return of post. They are very fast at doing that.

Re: The invisible unit

Posted: Sun Jan 12, 2020 2:02 pm
by Blodstrupmose
Hi and Thanks again.

Played around with the old 660 and it works perfectly in the same USB port.

GARMIN EXPRESS is set to start automatically.

Dont know about the power rating /outlet of the USB port. It charged the b*@#-%! thing so should it not be able to run it ?
It's not you i am swearing at.