660 issue while updating - SD card related

For everything Garmin Zumo 660/665 related
User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

660 issue while updating - SD card related

Post by Pete » Sun Jan 06, 2019 2:21 am

Hello,

I was searching online for a solution to my particular problem and this forum was recommended.

I was updating my Zumo 660 map normally (I have done this many times before) when it failed mid-update. The update was going on my 8 GB SD card. At around 62% it popped up a message that the download could not continue. I followed all troubleshooting steps to no avail. The Zumo would not detect on multiple PCs. I removed the SD card and it detected fine and would permit an update *IF* the Zumo had sufficient space. I put the SD card into my phone and it appears to be fine. The SD card has plenty of free space. I put the SD card back in the Zumo and it does not even complete the startup process while connected to the PCs. Should I format the card and start again? Do I need any of the files on the card? Please advise. Thank you in advance!

Note: The SD card is a Samsung 8GB that's perhaps 2 years old. Never a glitch in the past, strange that it seems to be AOK in my Samsung phone.

sussamb
Posts: 251
Joined: Mon Apr 23, 2018 1:06 pm
Been liked: 33 times
Great Britain

Re: 660 issue while updating - SD card related

Post by sussamb » Sun Jan 06, 2019 10:21 am

Well formatting the card would be my first step, but if your current map is on the card copy the files first, then you always have the option of reinstalling them if necessary.

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Sun Jan 06, 2019 1:23 pm

Here is some additional info (as I wait for the format to complete):

I put the SD card into my old Nuvi 1490 and that was just fine with it. It was detected by my pc, detected by Garmin Express and facilitated the transfer of files to my PC and access to the card by Windows 10 Disk Management. I'm hoping that the Zumo is just more "particular" and the FAT32 format resolves it.

To be extra cautious, I am not performing a quick format (which just overwrites the file allocation table), but instead, am performing a full (slow!) format.

rbentnail
Posts: 139
Joined: Mon Jun 18, 2018 10:14 am
Location: North Carolina USA
Has liked: 11 times
Been liked: 21 times
United States of America

Re: 660 issue while updating - SD card related

Post by rbentnail » Sun Jan 06, 2019 1:48 pm

Formatting may work, certainly can't hurt. But for the price I'd consider just buying a new card, maybe a 16gb this time. Don't know about the 660 but my 595 required no computer formatting prior to use, the Zumo took care of it when first inserted.
Russ B. Zumo 595,
2007 Yamaha FJR1300A, 117k and counting

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Sun Jan 06, 2019 1:59 pm

rbentnail wrote:
Sun Jan 06, 2019 1:48 pm
Formatting may work, certainly can't hurt. But for the price I'd consider just buying a new card, maybe a 16gb this time. Don't know about the 660 but my 595 required no computer formatting prior to use, the Zumo took care of it when first inserted.
Yes, there seems to be a problem with it. I'll just order a replacement. They are only about $10 US.

I think I may get a 32 gig card, however. The following is from the Garmin site (https://support.garmin.com/en-US/?faq=U ... mapupdates):

Model Maximum Capacity Card Type Class

zumo 220, 350, 390, 590, 660 32 GB microSD Class 2 to 10

https://www.amazon.com/Samsung-MicroSD- ... 1253503011

User avatar
Wingstyle
Posts: 64
Joined: Sat May 05, 2018 1:33 pm
Location: Texas
Been liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Wingstyle » Sun Jan 06, 2019 3:15 pm

Yes, there seems to be a problem with it. I'll just order a replacement. They are only about $10 US.
Pete,
Did the low-level format fail?

I have a 660 with a 16Gb micro-SD. That has been plenty of room for music and maps. However, the Garmin site does show that a 32Gb will work in the 660 and at that price why not.

There is a max number of mp3 files the 660 can handle (2000) and at 1982 mp3 files my 660 takes about 40 - 50 seconds to come ready. I have my files in folders with 10 files max in each folder. With no micro-SD, it takes about 20 seconds to come ready.

https://support.garmin.com/en-US/?faq=L ... tab=topics

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Sun Jan 06, 2019 3:55 pm

Wingstyle wrote:
Sun Jan 06, 2019 3:15 pm
Yes, there seems to be a problem with it. I'll just order a replacement. They are only about $10 US.
Pete,
Did the low-level format fail?

I have a 660 with a 16Gb micro-SD. That has been plenty of room for music and maps. However, the Garmin site does show that a 32Gb will work in the 660 and at that price why not.

There is a max number of mp3 files the 660 can handle (2000) and at 1982 mp3 files my 660 takes about 40 - 50 seconds to come ready. I have my files in folders with 10 files max in each folder. With no micro-SD, it takes about 20 seconds to come ready.

https://support.garmin.com/en-US/?faq=L ... tab=topics
The format did not "fail" (yet) but it is still running. As far as I am concerned, that means it's junk. It should only take a few minutes. I've already ordered the replacement; it should arrive on Tuesday. I went with the 32 GB simply because they are the same price as 16 GB MicroSD drives. Should I upgrade in the future (which I'll do when the Zumo finally gets a larger than 5" screen) then perhaps it will be useful.

I had 532 MP3s in a single folder but read about the speed improvement by using folders, so I will be reorganizing them when I put them back on the new SD card. I have a Sena 20 and I tried to set it up to use my old Samsung Note 3 with the Zumo, but it would only work properly immediately after setup, and after powering everything off and restarting, music on the phone sounded terrible. I've since replaced the Note 3 with a Galaxy S9+, and I will try again. Putting music on the GPS was a workaround that was not optimal, so I hope that it is not necessary moving forward.

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Sun Jan 06, 2019 9:54 pm

I hate to "give in" and let hardware "get the best of me" so I tried all day to format that stupid SD card. No matter what I tried, it always came back to having "1.46 GB free of 7.34 GB." It's as if it is write protected. I even tried to format it as NTFS which supposedly worked and showed the entire 8 GB available, but then I reformated it Fat32 and it went back to the original 1.46 GB free. I even put it back in my phone and tried to format it there, to no avail. So I guess I will finally admit defeat and await the new one on Tuesday. Hopefully, the Zumo will detect it.

Edit: As one last resort, I am trying this: https://www.sdcard.org/downloads/formatter_4/index.html
Attachments
2019-01-06 17_51_23-C__Users_Pete_Downloads.jpg
2019-01-06 17_51_23-C__Users_Pete_Downloads.jpg (23.59 KiB) Viewed 165 times

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Mon Jan 07, 2019 12:24 am

Frigging piece of $#!&! Rassen-frassen double blassen....

It wins... :oops: :cry:
Attachments
2019-01-06 19_22_17-Settings.jpg
2019-01-06 19_22_17-Settings.jpg (27.79 KiB) Viewed 163 times

User avatar
Pete
Posts: 8
Joined: Sun Jan 06, 2019 2:14 am
Location: East Berlin, Pennsylvania - USA
Has liked: 6 times
United States of America

Re: 660 issue while updating - SD card related

Post by Pete » Tue Jan 08, 2019 10:34 pm

New 32 Gig card arrived. Detected with no problem. Very strange. I have been in the computer industry since 1997, and this is the first time I have had an SD card fail in this fashion.

Oh well, there is always a first. Now I have room for more music. (Silver lining!)

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 0 guests